+1 maintenance report - Week 41 (with upils subbing in)

Simon Chopin simon.chopin at canonical.com
Mon Oct 16 10:40:39 UTC 2023

Hi all,

During the release week, we decided to still do a +1 rotation: as in
yours truly. I was supposed to be shadowed by Paul Mars (upils), but it
turns out that Paul ended up going off on his own since I had some last
minute release-related things to investigate, some paperwork to do,

I'll adjoin his report at the bottom, to avoid it being stuck in the
moderation queue.

## delve FTBFS

As suspected, there weren't low-hanging fruits standing out, so we
started off looking into FTBFSes, more specifically src:delve, the
Golang debugger.

The investigation had quite a bit twists and turns, and was quite a bit
painful since we weren't able to reproduce it on the usptream test
suite. For a while we assumed it was due to a change in the golang
dependencies, but eventually Paul figured out that the issue was that
the test program used in the fixtures was panicking when setting a
timezone. Naturally, this provoked issues when the debugger tried to
read local variables defined *after* the panic.

The easiest fix for this is to add a tzdata-legacy build-dependency, but
of course the best fix is to actually use a "normal" timezone using the
Continent/City pattern, which is what Paul did and immediatly forwarded
to Debian, where is appears to be fixed:


## borgbackup2 FTBFS

The issue is missing testfiles when pybuild runs the test suite in a
test directory. I spent quite a bit of time trying to force pybuild to
copy them over using debian/pybuild.testfiles, but that feature wasn't
flexible enough.

I ended up patching the manifest file to add the missing data, as it's
supposed to be handled by a plugin detecting versioned files, which
obviously doesn't work when building out of tarballs. The patch has been
forwarded to Debian (https://bugs.debian.org/1052875), but for upstream
that approach is not the right way forward (and I agree):


Below is Paul's report, unedited:

- delve
    - Solved the FTBFS, fixed merged in debian package [0] and in upstream
project [1]
- dh-make-golang
    - Same FTBFS on debian
- `golang.org/x/tools/go/vcs` is now deprecated and was removed from golang
    - Opened an issue [2], waiting for a reply to see if the project is
still maintained.
- fscrypt
    - reproduced locally FTBFS for ppc64el
    - Failing because `unix.Mmap(-1, 0, length, keyProtection, flags)` (see
`crypto/key.go`) is returning an error.
    - I was unable to understand why this is failing for ppc64el. I guess
the underlying syscall is not implemented the same way.
- ironic
    - reproduced autopkgtest fail locally
    - Caused by `Broken python3-service-identity:amd64 Depends on
python3-pyasn1:amd64`. So some python dependencies may be broken.
- exec-path-from-shell-el
    - Unable to reproduce locally
    - Caused by `Failed to download ‘melpa’ archive.`
    - I am trying today a fix using a specific TLS version.

[0] https://salsa.debian.org/go-team/packages/delve/-/merge_requests/2
[1] https://github.com/go-delve/delve/pull/3527
[2]  https://github.com/Debian/dh-make-golang/issues/200

More information about the ubuntu-devel mailing list