nodejs in groovy-proposed? (Re: +1 maintenance report)

Brian Murray brian at
Thu Aug 13 20:05:26 UTC 2020

On Tue, Aug 11, 2020 at 04:21:24PM -0700, Brian Murray wrote:
> On Tue, Aug 11, 2020 at 02:13:40PM -0700, Bryce Harrington wrote:
> > On Tue, Aug 11, 2020 at 01:02:27PM -0700, Steve Langasek wrote:
> > > On Tue, Aug 11, 2020 at 09:55:16AM -0700, Bryce Harrington wrote:
> > > 
> > > > Could someone give a status update on the icu and json-c transitions?
> > > > I see they've been progressing daily, but curious since server team has
> > > > a few packages blocked from migrating.
> > > 
> > > The big problem I see right now is nodejs, which seems to have made a
> > > complete mess of the autopkgtests of its revdeps.  I'd be interested to know
> > > if anyone is working on this and sees indications that it's tractable, or if
> > > we should just revert nodejs for now.
> > 
> > I worked on it quite a bit during my +1 maintenance shift a couple weeks
> > ago.  It has indeed been a huge mess, but it has definitely gotten a lot
> > better.  Looks to me like there's just three problems remaining for
> > nodejs itself:
> > 
> > a.  The main remaining issue is that for three of the packages there is a
> > bug on pcc64el with SHA1 encryption[1], which osomon has been working
> > on, and found to be due to a compiler optimization error.  He forwarded
> > it upstream[2] and yesterday upstream provided a patch to test[3].  So
> > this looks like it's on a path to be solved soon.
> > 
> > b.  Another three packages appear to be hitting timeouts on autopkgtests,
> > for arm64 only.  Their test histories look like they mostly fail with
> > scattered random passes.  Maybe a flaky test?  Maybe re-running it a few
> > times will resolve them?
> I'm running the tests for one of these packages, node-redis, with
> a longer timeout value and if that passes we could add it to the
> "long_tests" group[1].

node-redis did end up passing for me on an arm64 unit in Canonistack
although I didn't need to make any changes to --timeout-test.
Regardless, the package was added to long_tests.

I also tested node-immutable-tuple on an arm64 unit in Canonistack
(before the new nodejs was removed from the archive) and it failed for
me there. Its worth noting that the failure was with a specific test
timing out, not the whole test run timing out as was the case with
node-redis. I then ran the node-immutable-tuple tests on an m1.large
unit in Canonistack and the tests passed so I've added them to
big_packages on arm64[1].


Brian Murray

More information about the ubuntu-devel mailing list