Infiniband mstflint package SRU with new HW support provided by Mellanox

Seth Arnold seth.arnold at canonical.com
Fri Jan 8 09:22:59 UTC 2016


On Fri, Jan 08, 2016 at 01:56:38AM -0200, Rafael David Tinoco wrote:
> https://bugs.launchpad.net/ubuntu/+source/mstflint/+bug/1470167
> 
> There is a direct request from Mellanox for Ubuntu to sync "mstflint"
> package with Debian.
> 
> While that is okay for Xenial, after bisecting mstflint code with
> ConnectX-4 HBAs, I could see the exact commit that brings ConnectX-4
> HBAs support to mstflint is huge and does not fit into SRU guidelines.

A further comment in the bug reports that the mstflint in 14.04 LTS is
also too old to flash ConnectX-3 cards. While I might not expect trusty
to handle the ConnectX-4 cards out of the box I certainly would expect
ConnectX-3 to work.

I'd vote for the SRU of the newest package to the currently supported
releases where it makes sense. Our "new" SRU policy ought to make this an
easier task, and as mstflint is unlikely to have many depedencies, the
testing for it ought to be reasonable enough.

Thanks
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-devel/attachments/20160108/ca838f8f/attachment.pgp>


More information about the ubuntu-devel mailing list