System indicators will drop GTK2 support in quantal

Sebastien Bacher seb128 at
Fri Jun 29 16:21:51 UTC 2012


I'm not sure how well that got communicated after UDS so I'm sending an 
email to the devel list.

With the LTS out the dx indicators' team is dropping gtk2 support for 
indicator-* this cycle (i.e the system indicators: 
indicator-session,messages,etc), they will still keep gtk2 versions of 
the libraries so there should be no issue for applications.

I'm not sure what are the plans e.g xfce and GTK3 and if indicators are 
used there but if that's an issue for xubuntu or other derivates please 
let us know which ones you need so we can work together on a solution 
(which could be to upload a different source with the precise version of 
the needed indicators to build with gtk2 for example).

Sebastien Bacher

More information about the ubuntu-devel mailing list