Installing on RAID with Ubiquity [was: Proposal to drop Ubuntu alternate CDs for 12.10]

Dmitrijs Ledkovs dmitrij.ledkov at
Tue Aug 28 07:42:26 UTC 2012

On 28/08/12 06:38, Martin Pitt wrote:
> Hello Steve,
> Steve Langasek [2012-08-27 14:50 -0700]:
>>  - RAID is relatively straightforward to turn on post-install.  You install
>>    to one disk, boot to the system, assemble a degraded RAID with the other
>>    disks, copy your data, reboot to the degraded RAID, and finally merge
>>    your install disk into the array.  It's not quick, but it's *possible*.
> I got curious and tried it the other way: I used gparted for creating
> my partitions, installed mdadm in the live system and used it to build
> a /dev/md0, then told Ubiquity to create partitions in that and
> install to it. That part worked fine.
> After Ubiquity was done, there is some unnecessary "fun" though, which
> might still be fixable for Quantal:
>  * It would be nice if Ubiquity could install mdadm for me if it sees
>    that any of its target partitions are on /dev/md*.
>    To do this manually, I tried:
>    * mount /dev/md0p1 /target, chroot /target
>    * apt-get install mdadm; that fails because /etc/resolv.conf is
>      empty, so exit chroot, apt-get download mdadm, copy to
>      /target/tmp, chroot again, dpkg -i
>    * that fails because it cannot access /dev etc, so back out of the
>      chroot, bind-mount /dev/, back into the chroot, dpkg
>      --configure -a, get scared by the warnings about not being able
>      to load MD suppport
>    If ubiquity would install it along with its other setup, these
>    would be avoided.

Yes, that could be done, even this cycle.

>  * After that, booting fails because the generated grub configuration
>    hardcodes /dev/md0p1, but initramfs/kernel create it as /dev/md127p1. 
>    It would be nice if grub/Ubiquity used UUIDs for the root partition
>    as usual; in the initramfs /dev/disks/by-uuid/... exists just fine.

Why mdadm started to generate md127 instead of md0, I don't know. And
it's a bug I should look into.

If you search mdadm package bugs for UUID, there is plenty demand for
it. Using UUIDs fail when lvm is on top of raid, or raid is on top of
crypt (as raid device is not seen). But it is definitely the direction
we should aim for.

I am assigned to work on this as part of:

> After that, the system boots just fine. I think this approach is still
> faster than post-install setup of RAID.
> Is it desirable/possible to fix these issues? If so, I'm happy to file
> two bugs for these issues.

One is known, and I will incorporate the other one into the ubiquity
raid blueprint, once I get the ownership of that one on launchpad.

> Thanks,
> Martin

Thank you for power-user testing this =)

> P.S. +1 from me for dropping Alternates.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 897 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the ubuntu-devel mailing list