Analysis of Python 2.7 support in Natty

Stefano Rivera stefanor at
Fri Feb 4 09:01:06 UTC 2011

Hi Stephan (2011.02.04_10:51:04_+0200)
> I don't think we are dropping Python 2.6 from the archives, I hope it
> will just be demoted from Main to Universe, so packages (!main) which
> are still depending on 2.6 will build in universe without problems.

Unfortunately, it's not that simple. The python-defaults package needs
to know which pythons are supported. python-support and -central also
need to (IIRC).

Packages don't depend on 2.6, they just build with all available
versions, and that means if they have C extensions, they'll depend on

It wouldn't be *impossible* to implement what you suggest, but I can't
see it being easy.


Stefano Rivera
  H: +27 21 465 6908 C: +27 72 419 8559  UCT: x3127

More information about the ubuntu-devel mailing list