We'd like you to use Launchpad web service version "1.0" in Lucid
jw+debian at jameswestby.net
Tue Mar 30 19:57:41 BST 2010
On Tue, 30 Mar 2010 11:32:28 -0700, Kees Cook <kees at ubuntu.com> wrote:
> On Tue, Mar 30, 2010 at 05:57:57PM +0200, Martin Pitt wrote:
> > Leonard Richardson [2010-03-30 10:44 -0400]:
> > > 1. When testing, make sure you're using launchpadlib 1.5.7 or later. A
> > > bug in earlier versions made launchpadlib use the 'beta' service in some
> > > circumstances even when you told it to use another version.
> > Right, that's what I stumbled on today, too. I synced 1.5.7 into lucid
> > now, and extensively tested with Apport.
> > Please bump the binary dependencies accordingly when doing the
> > porting.
> To detect this at run-time, I'm using:
> if launchpadlib.__version__ < '1.5.7':
> raise ValueError, "Requires launchpadlib version 1.5.7 or later (%s in use)" % (launchpadlib.__version__)
You realise this is string comparison and if launchpad makes it to
1.5.10 it will tell them they need at least 1.5.7 and refuse to work?
More information about the ubuntu-devel