20090929.2 UEC install test

Matt Zimmerman mdz at canonical.com
Wed Sep 30 16:03:34 BST 2009

On Wed, Sep 30, 2009 at 02:44:10PM +0200, Thierry Carrez wrote:
> Thierry Carrez wrote:
> > However my preliminary testing shows that eucalyptus needs to be
> > stopped/started *after registration succeeded* to take the registration
> > into account... I'll confirm that bug with the ISO install, when it will
> > be published.
> > [...]
> A full 20090930.1 test failed to run instances.
> There is some condition on the NC that makes it believe walrus is
> running on, though it is reported as correctly registered on
> the cluster side.
> I tried various ways to unregister and manually register it, to no
> avail. This is late for fixing this for beta. So I made the decision to
> revert to the previous known state, 20090930.

Just to be clear: if you're reverting to 20090930 as the candidate
installation image, you need to roll back at least the Eucalyptus package to
the same state, both for the sake of upgrades and so that we can re-roll new
candidates with other last-minute fixes if necessary.

> Running that release I could make it actually start instances. It's not
> free of bugs, but at least we know how to document their workarounds.
> Here are the things against 20090930:
>  * Requires manual registration and restart of eucalyptus before it can
> be used
>  * Starting an instance can fail with a 500 Walrus error
> I'll verify and file bugs for each.

I haven't had a chance to look over the test reports yet; are there other
problem areas apart from Eucalyptus for beta?

 - mdz

More information about the ubuntu-devel mailing list