UEC/Eucalyptus installation test: 20090927.1

Matt Zimmerman mdz at canonical.com
Mon Sep 28 15:00:57 BST 2009

On Mon, Sep 28, 2009 at 10:10:30AM +0200, Thierry Carrez wrote:
> Thierry Carrez wrote:
> > Matt Zimmerman wrote:
> >> I've pushed a branch to:
> >>
> >> https://edge.launchpad.net/~mdz/eucalyptus/auto-registration
> >>
> >> which implements automatic registration of SC, CC and Walrus using upstart.
> > 
> > That's great, I'll test that right away.
> So I did a UEC install / cluster mode from 20090927.1 and confirmed that
> the components were not registered. I then upgraded to eucalyptus
> packages built from the auto-registration branch. Just after the
> packages were installed, the components were still not registered, but a
> few dozens of seconds later everything was in place automatically.

That's expected.  It waits for all of the services to be fully up and
responding and then attempts registration asynchronously (which takes some
time itself).

Due to the fact that the SC, Walrus and Cloud all run in the same process,
it needs to be restarted each time one of the components is installed or
removed.  If that were changed, the installation would run much faster, but
I think it's good enough for beta.

> The only modification I did on the cluster was to add a VNET_PUBLICIPS=
> line with a valid IP address to /etc/eucalyptus/eucalyptus.conf, then
> sudo service eucalyptus restart

Could you test doing this using dpkg-reconfigure?

> >> Testing of both cluster and node would be greatly appreciated.  I'd like to
> >> get this uploaded in the morning once someone else has validated it, and get
> >> it onto server ISOs ASAP after that.
> > 
> > I'm on it.
> Did the UEC install / node mode from 20090927.1, no problem. Once the
> node is up, I did on the front-end:
> $ sudo euca_conf --discover-nodes
> But the node didn't start to show sync in /var/log/eucalyptus/nc.log

Has this ever worked previously?

> Looking back at the cluster controller there is an issue which may be
> related to registration:
> Repeated in httpd-cc_error_log:
> [Mon Sep 28 10:08:53 2009] [notice] child pid 4416 exit signal
> Segmentation fault (11)

I noticed this once as well.

> Once, in /var/log/eucalyptus/axis2c.log:
> [Mon Sep 28 10:06:20 2009] [error] http_transport_utils.c(2557) Service
> or operation not found
> I'm investigating that.

I haven't noticed this (but haven't looked for it either).

 - mdz

More information about the ubuntu-devel mailing list