today's UEC report

Dustin Kirkland kirkland at
Sat Oct 3 19:02:06 BST 2009

On Sat, Oct 3, 2009 at 5:13 AM, Matt Zimmerman <mdz at> wrote:
> I'm sorry to hear it was so slow.  I think it will be better on Monday after
> the beta peak subsides.  I'm running an update right now and getting
> 200kB/sec, which is not fantastic but lets me get work done.

Still coming down pretty slow for me right now.

8% [14 g++-4.4 5654122/5,785kB 97%]                  8,435B/s 10h 4min 6s

I normally pull from the archive at about 1-2MB/s.

> Are you referring to this issue?
> open-iscsi (2.0.870.1-0ubuntu12) karmic; urgency=low
>  * debian/open-iscsi-udeb.finish-install: Stop checking
>    disk-detect/iscsi/enable, as that template doesn't exist any more.
> or something else?

That's it.  It's fixed now.

> When you say "installs from ISO are broken", do you mean all installations,
> or only ones which use iSCSI?

Yes, all ISO installs were broken.  At the end of the installation,
instead of informing you that the install had finished, remove the
install media, and reboot, you were returned to the installation menu,
without a way to cleanly finish the install and reboot.  Colin pointed
me to remove /usr/lib/something/blah-iscsi, and then rerun the
finish-install step, and that worked.

>> Next, the Upstart issues were not fixed in Scott's last upload.  Looks
>> like its supposed to remove /etc/init/dbus-reconnect.conf, but didn't.
>> I showed Scott this, and he fix that too.
> This seems to be fixed here:
> upstart (0.6.3-7) karmic; urgency=low
>  * Ignore initramfs pids that don't exist.  LP: #440071.
>    - you still need to ensure that the pid's parent is init, there's no
>      cheap way to test for that.
>  * Remove "console owner" and "console output" from rc scripts.
>  * Try harder to remove dbus-reconnect.conf


>> I was able to hack my way around both of those issues to get my cloud
>> installed.  Unfortunately, registration and running instances are not
>> working very well at this point.
> What's wrong with registration?

It was working sporadically for me.  Dan pointed at the database
wedging as being the issue.

>> Dan logged into my box, poked around a bit, and found that my database
>> was wedged.  He said this is issue LP: #436885, and should be fixed in
>> our next merge.
>> I tried for several hours to work around this issue, but couldn't.
> Sounds very frustrating.  If it was 436885, I wonder why you're hitting it
> so readily now, when it wasn't happening to us at all in previous
> small-scale testing.

Great question.  I don't know.  Dan/Rich said that we would hit this
at a "non-deterministic point in the future".  This is absolutely
something we have to fix by release, as I was pulling my hair out.


More information about the ubuntu-devel mailing list