Proposal: add rarian-compat Pre-depends to fixed xml-core

Martin Pitt martin.pitt at ubuntu.com
Thu Oct 16 15:35:44 BST 2008


Martin Pitt [2008-10-14 12:39 +0200]:
> What's left now is to ensure that it will actually be used during the
> upgrade. For us, the problem manifests on replacing scrollkeeper with
> rarian-compat, since both calls update-xmlcatalog. Therefore I propose
> to add 
> 
>   Pre-Depends: xml-core (>= 0.11ubuntu1)
> 
> to rarian-compat, so that the fixed script is guaranteed to be
> available even for the old (hardy) scrollkeeper postrm and
> rarian-compat's prerm. See [4] for my proposed debdiff.

For the record, I uploaded that yesterday after getting an "eek, but
ack" from Steve Langasek. Please shout if anybody sees a problem with
this.

Thanks,

Martin

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : https://lists.ubuntu.com/archives/ubuntu-devel/attachments/20081016/87ea929f/attachment.pgp 


More information about the ubuntu-devel mailing list