[MOTU Work] Octave3.0 Transition

Stephan Hermann sh at sourcecode.de
Fri Jan 25 14:47:58 GMT 2008

Dear Colleagues,

Debian has in SID the new octave3.0 version handy.
For this to have in hardy, I'm preparing the octave2.9 to octave3.0

As you can read on
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=457675 octave packages
< 3.0 will go away soon.

And for Hardy I think it will be a good sign to our Users and Customers
ot provide a long awaited stable version for octave (means 3.0).

After finishing the packages mentioned below and in the resulting bug
report, I'll confirm the sync req again for octave 3.0 and file two
removal requests for octave2.1 and octave2.9

Regarding the comments on:


I examined our source archive, and the following packages have direct
build-depends/build-depends-indep on octave2.9|octave2.1|octave

Package: octave-gpc
Version: 0.1.6-4build1
Build-Depends: debhelper, octave2.1-headers (>= 2.1.72-10),
libgpcl-dev, cdbs

Package: h5utils
Version: 1.10-7
Build-Depends: debhelper (>= 5), libhdf5-serial-dev (>= 1.6.5),
libz-dev, libpng-dev, hdf5-tools, libhdf4g-dev, libmatheval1-dev,

Package: inline-octave
Version: 0.22-2
Build-Depends: debhelper (>= 4), dpatch
Build-Depends-Indep: libinline-perl, octave2.1

Package: matwrap
Version: 0.57-8
Build-Depends: debhelper (>= 4.0.0), cdbs
Build-Depends-Indep: octave2.1-headers | octave2.9-headers

Package: octave-epstk
Version: 2.2-6
Build-Depends: debhelper (>= 5), cdbs, gs-common
Build-Depends-Indep: octave2.1-headers (>= 2.1.73-10),
octave2.9-headers (>= 2.9.7-2)

Package: octave2.1-forge
Version: 2006.03.17+dfsg1-4build2
Build-Depends: debhelper (>= 5), octave2.1-headers (>= 1:2.1.73-9),
libxt-dev, gfortran, libqhull-dev, libginac-dev (>= 1.3.3-2+b1),
libgmp3-dev, autoconf, libjpeg62-dev, libpng12-dev, libncurses5-dev,
libreadline5-dev, texlive-generic-recommended, libgsl0-dev,
netcdfg-dev, units, cdbs 

Package: octaviz
Version: 0.4.5-5build1
Build-Depends: debhelper (>= 5.0.0), cmake, libvtk5-dev (>= 5.0.1-4),
octave2.1-headers (>= 2.1.72-9), lesstif2-dev, cdbs

Package: octplot
Version: 0.4.0-4build1
Build-Depends: debhelper (>= 5), octave2.9-headers (>= 2.9.7-2),
libfltk1.1-dev (>= 1.1.4), xlibmesa-gl-dev, libglu1-xorg-dev |
libglu-dev, libfreetype6-dev, cdbs, automake1.9 

Package: pfstools
Version: 1.6.2-1ubuntu2
Build-Depends: debhelper (>= 5), gfortran, autotools-dev,
libqt3-mt-dev, libmagick++9-dev, libtiff4-dev, libopenexr-dev,
libnetpbm10-dev, octave2.1-headers, tetex-bin, freeglut3-dev

Package: plplot
Version: 5.6.1-11ubuntu2
Build-Depends: debhelper (>=, tcl8.4-dev, tk8.4-dev,
itcl3-dev, libx11-dev, libxext-dev, libxi-dev, gfortran, itk3-dev,
octave2.1-headers (>= 2.1.65), libgd2-noxpm-dev | libgd2-xpm-dev,
libgnome2-dev, libgnomeprintui2.2-dev, libgnomeui-dev, m4,
libqhull-dev, libxml-parser-perl, libxml-dom-perl, matwrap,
autotools-dev, libltdl3-dev, pkg-config, dpatch, atlas3-base-dev
[!arm !m68k], refblas3-dev [arm m68k], lapack3-dev [arm m68k],
python-gtk2-dev, liblasi-dev (>= 1.0.5-2), libwxgtk2.6-dev,
python-gnome2-dev, python-all-dev (>= 2.3.5-11), python-central (>=
0.5), python-numeric (>= 24.2-3), ttf-freefont 

Package: semidef-oct
Version: 1:2003-5build1
Build-Depends: octave2.9-headers (>= 1:2.9.13-1), debhelper (>= 3.0.0),

Package: shogun
Version: 0.4.4-1
Build-Depends: atlas3-base-dev [!arm], cdbs, debhelper, lapack3-dev,
libreadline5-dev, octave2.9-headers, python-all-dev, python-central (>=
0.5), python-numpy-dev, python-numpy-ext, quilt, r-base-core,
refblas3-dev, swig, xutils-dev

Package: xmds
Version: 1.6.3-1ubuntu1
Build-Depends: cdbs, debhelper (>= 5), autotools-dev, fftw-dev,
libfftw3-dev, libmpich1.0-dev, octave2.1-headers, octave2.9-headers,

Some of the packages are just building without problems. Some others
(like e.g. pfstools are in need of some patches, which are on the
debian bts or you have to find out a solution by yourself). I prepared
most of the packages on my local harddrive, so after octave3.0 hits the
archive I'll upload or request a sync.

I'll file a bug report about the transition and add all packages which
are affected to it. 			
Furthermore I'll add debdiffs to the resulting package bugs.

There are some other packages which are binary depending on
octave <insert version here>, which are in need of an updated
debian/control file. I'll add them to the list, too, hopefully with a
debdiff or sync request attached.

Any Questions? Please ping me on freenode (\sh) or reply to this mail. 



SysAdmin, OSS Developer
GPG-Key ID: 0xC098EFA8 
Fingerprint: 3D8B 5138 0852 DA7A B83F  DCCB C189 E733 C098 EFA8

More information about the ubuntu-devel mailing list