installation report D430, tribe4, 64-bit.

Robert Collins robertc at
Wed Aug 15 09:24:12 BST 2007

Executive summary: Woot, we have a working system.

More details follow. I haven't filed bugs on the glitches encountered
herein - yet. I figure some are 'you're doing crypted disks, DEAL'.
Whereas others are genuine - and I need some feedback on which is which.

I looked at the ISO testing web page, but I was really not sure what I
should do with my notes: this wasn't an executed test plan, it was 'I
have a new machine, lets get it going, and see what breaks'. I hope its
ok that I have sent it here, and I think the ISO testing web pages
should include some guidance for adhoc tests.

Machine configuration: 
 - abgn wifi
 - bluetooth
 - 2gb ram
 - 80g drive
 - u7600 CPU
 - fingerprint reader
 - no cellular module

1) unpack
2) go to bios, disable HDD as boot - don't want the included windows
3) plug in DVD, insert tribe4/64, boot
4) 'no bootable media'
5) test random 32 bit cd - boots
6) futz around with alternate 64 bit boot discs, none of which work
7) run the diagnostics - the rom ones, not CD ones, no errors up to the
point it chains to hard disk, but the diagnostic partion is apparently
not there/ready yet.
8) accidentally try booting a 64-bit CD, which now boots.
9) boot screen has the progress bar off-center, otherwise fine
10) graphics comes up lovely.
11) network (pci id 8086:4229, rev 61) seems to be there but network
manager crashes when I ask it to connect to another wifi network (e.g.
12) stop network manager
13) manually set essid, run dhclient - network is fine
14) on the web, browsing your sites
15) mozilla window opens taller than the visible screen - the bottom
status tab is not visible behind the bottom panel
16) Curiosity killed the cat: went to appearance prefs, desktop effects,
clicked Extra Effects, and:
 'Nvidia hardware not available' pops up, click close, it starts to
disappear and the machine wedges. Can still ping it, can't ctrl-alt-f1
though, and ssh isn't installed.
17) reboot, do cryptsetup foo giving me sda2 as luks volume, lvm on that
    and /dev/mapper/vg-swap and /dev/mapper/vg-root
18) run the installer, ... manual partitioning and while I see a huge  
    number of dm-X devices, the ones that I want - the swap and root are
    *only* identifiable by the fact that their type is noted. Would be
    great to show /dev/mapper/vg-swap etc.
19) very long delay - several minutes? on 'Configuring hardware'.
20) mounted the install and installed hashalot, regenerated the
initramfs and checked it had a crypt config, removed the UUID from the
root line in the grub menu, ran update-grub.
21) reboot - grub error:
Error 15: File not found

Press any key to continue
22) Turns out the grub setup was confused - rather than /vmlin... the
paths were /boot/vmlin.... (yay grub). [Note, update-grub after getting
the system booting properly fixed this - step 32]
23) Boot, enter password for luks - something queer, it prompted and
seemed to accept but didn't advance the boot process. 
24) Wait for timeout. 
25) ... lvm was missing. 
26) reboot to CD, mounted the install, installed lvm. Regen initramfs,
27) Goes through the boot properly this time, but prompts me for my disk
encryption password *again* sometime during init. ('Starting Early
28) Login screen. YAY!
29) username, password, lovely tan background but no UI. Mouse still
30) ctrl-alt-F1 etc give a black screen, no login prompt.
31) power-off, reboot
32) Tried a console login - worked fine, update-grub to fix menu.lst.
33) login attempt again
34) hangs again
35) console login, kill NM, manually bring up the network
36) switch to the gui, login - works.
37) Kick off update-manager, go get a coffee, nothing to see here.

Clearly some of the issues above are my own (missing lvm2 packge - duh).
Others though I'm less clear on. Feedback solicited and appreciated.


GPG key available at: <>.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : 

More information about the ubuntu-devel mailing list