NetworkManager packages for testing

Raphael Schneider rasch_sub at
Fri Apr 13 09:59:07 BST 2007


On Donnerstag 12 April 2007, Scott James Remnant wrote:
> If you are having problems with Network Manager in feisty, specifically
> that the applet claims that it is not connected, please try the source
> package at the following URL, which should solve the problem:
Tried the new source and at seems that the problems is not gone. Running 
Kubuntu on a Thinkpad T60 using KNetworkManager. Version 0.6.4-6ubuntu4 
worked fine, when attached to the wired network, the corresponding icon was 
shown, when atached to WLAN, the connectivity level was shown. After updating 
to 0.6.4-6ubuntu5 only the 'not-connected' icon is showing and in the menu of 
the applet is an entry saying 'no network device found' (or similar; it is in 
German). With the new source I have the same behavior.

After looking in the source for version 0.6.4-6ubuntu4 and 0.6.4-6ubuntu7 
maybe the problem is in function nm_system_device_get_disabled() in 
src/backends/NetworkManagerDebian.c . In version 0.6.4-6ubuntu4 the last 
check ('If the interface has no options other than just "inet dhcp" it's 
probably ok to fiddle with it.') was disabled. In the current version the 
check is done. When a manual configuration was done, there are other options 
in /etc/network/interface which sets the device on the blacklist.

I have no experience how the network interface settings stuff works internal 
(I am just a user of the GUI controling programs/applets) but version 
0.6.4-6ubuntu4 worked for me most of the time (when switching from WLAN to 
LAN I had to re-load the manual settings because the DNS entries where not 

Hope this helps.


More information about the ubuntu-devel mailing list