Accepted ndiswrapper 1.38-1ubuntu1 (source)

Matt Zimmerman mdz at
Wed Apr 4 14:01:54 BST 2007

On Wed, Apr 04, 2007 at 08:19:31AM +0300, Timo Aaltonen wrote:
> On Tue, 3 Apr 2007, Matt Zimmerman wrote:
> > The source is available in the ndiswrapper source package, and also in the
> > Ubuntu kernel source package.  I don't think we need another copy, and it's
> > confusing.
> Ok, fine by me, I'll remove it. The custom builders can grab the source 
> from the kernel..
> > We removed some similar -source module packages, because people would use
> > them without realizing that the modules were already in the kernel, causing
> > confusing problems.
> wacom-kernel-source might be another candidate.
> > Has anything been done about the package name transition?  Is there still an
> > issue there?
> There's only ndiswrapper-utils-1.9 available, so I don't understand what 
> the problem is..

The trouble is that users installed ndiswrapper-utils (naturally), then the
kernel was updated to an incompatible version which only worked with
ndiswrapper-utils-x.y, and users with ndiswrapper-utils were hosed until
they figured out that they needed to install ndiswrapper-utils-x.y instead.

ndiswrapper-utils should always match what's in the Ubuntu kernel.

 - mdz

More information about the ubuntu-devel mailing list