Flight 5: passing 'psmouse' kernel argument broken?

Stephen Hemminger shemminger at osdl.org
Tue Mar 21 05:25:23 GMT 2006


On Mon, 20 Mar 2006 23:52:24 -0500
Obi Bok <obibok at gmail.com> wrote:

> I use a KVM switch which has an annoying side effect that makes the mouse 
> pointer jump all over the display after switching to another PC and back. 
> Fortunately, there's a fix for that by simply passing 'psmouse.proto=imps' to 
> kernel (alternatively 'psmouse.proto=bare' but it disables the mouse wheel). 
> It worked as expected in Breezy (also tested with success in the latest SuSE 
> and Fedora) but seems to be broken in Dapper - Flight 5.
> 
> Instead of the kernel argument, I tried 'psmouse proto=imps' in /etc/modules 
> but it didn't work. Just out of curiosity I also tried changing:
> Option          "Protocol"              "ExplorerPS/2"
> 
> to:
> Option          "Protocol"              "ImPS/2"
> 
> in /etc/X11/xorg.conf but it made no difference. At this point I need to 
> manually 'rmmod psmouse' and 'modprobe psmouse' every time I switch between 
> systems. Can anyone else test this? Any ideas if this has to do with the 
> kernel or if it's Dapper specific?
> 

Since ubuntu build psmouse as kernel module you need to put

options psmouse proto=imps

into a file in /etc/modprobe.d directory



More information about the ubuntu-devel mailing list