ubuntu-desktop: remove python-gdchart dep

Daniel Robitaille robitaille at gmail.com
Thu Jan 26 03:32:06 GMT 2006

> "Apparently ubuntu-desktop 0.91 depends on an arbitrary library and/or
> python extension; removing these only removes ubuntu-desktop.  Is there
> any particular reason for this dependency, or is it legacy and removable?"
> Let's try this again:  *NO* *APPLICATIONS* *APPEAR* *TO* *DEPEND* *ON*
> *python-gdchart* *ACCORDING* *TO* *APT*.  Is there something I'm missing
> here, or does your response:
> "python-gdchart needs to be updated for libgd2.  Unfortunately, this
> will require some code changes and is not simply a matter of rebuilding,
> so it make take some time before it catches up."
> indicate that some frivilous developer also happens to be a python fan
> and is installing arbitrary packages he likes to use that the rest of us

The identity of that frivilous developer will become clear if you read
the comment in this old bug report:

Bug #12395: "ubuntu-desktop depends on too much and useless packages
for a desktop"

Daniel Robitaille

More information about the ubuntu-devel mailing list