how to request a package update?

Alexandre Strube surak at surak.eti.br
Mon Apr 24 13:25:04 BST 2006


Em Seg, 2006-04-24 às 14:02 +0200, Rakotomandimby Mihamina escreveu:
> It is about libdvdread, the 0.9.5 is out, but only the 0.9.4 is
> available.
> How to request an update of this package?

Someone, please correct me if I'm wrong.

There are different processes according with the package.

If the package is in main, the only way to have it updated is between
releases. If the new release cycle is in the beginning, just ask for the
maintainer (it will probably be sync'ed from Debian anyway). It's not
the case now. Today, you have to ask for a exception in the Ubuntu
Version Freeze (uvf). But the only accepted updates are those which
fixes bugs, and doesn't add any new features (which might introduce new
problems). This process is analyzed case-by-case.

Oh, the new release must be in Debian.

If the package is in Universe and Multiverse repositories, the process
is easier, there's no need to ask for exception, and the package can
even add new features. Just find out who is responsible for it and make
him/her aware that this update is desired.


-- 
Alexandre Strube <surak at surak.eti.br>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/ubuntu-devel/attachments/20060424/50a60098/attachment.pgp


More information about the ubuntu-devel mailing list