Array 5 liveCD - report (X11, ide issues; suspend success)

Zack Weinberg zack at
Sun Feb 20 16:53:49 CST 2005

Today I tried out the HoaryHedgehog Array 5 live CD on my laptop.
This is a Dell Latitude C840, currently running Debian unstable with a
2.6.10 kernel, and I was hoping Ubuntu would solve a small number of
very specific problems which I have with this system.

The first problem I was hoping to solve, is that since upgrading to
kernel 2.6 and ACPI (which has otherwise been quite nice, e.g. battery
life is improved) I have not been able to use suspend-to-RAM.  This
used to work perfectly with 2.4 and APM.  I'm pleased to report that
following the directions at
also works perfectly, from a text console or from an X session.  (A
minor improvement would be, from an X session, to present the
xscreensaver unlock dialogue immediately on resume - I had to guess
that the reason I was seeing a black screen was because the
screensaver was active.)

Unfortunately, the other major problem I have is not addressed by
Ubuntu.  I have a docking station for this laptop.  Under Windows, one
may suspend to RAM, dock the laptop, and resume, and the display
automagically switches to the docking station's monitor.  This does
not happen under Linux.  This is a kernel-level problem: it doesn't
work even in a text console.  I have played with related BIOS settings
with no success.  The best I can do is, if the computer is initially
booted while in the docking station, then it will display to the
docking station's monitor - but if suspended, removed, and resumed, it
won't display to its LCD panel!

While I'm complaining about X issues, this annoyance isn't fixed in
Ubuntu either: If I am in an X session, and I close the lid, when I
reopen it the backlight does not turn back on.  I must press Fn+F8
(the magic direct-to-BIOS sequence to switch between the LCD panel and
the external VGA connector).  I then get a garbled screen.  Switching
to a text console and back corrects the display.  David Dawes gave me
to understand this was fixed in the XFree86 4.4 "nv" driver, so I was
really hoping it would be fixed in Xorg whosis as well...

A few other comments: 

 - The LiveCD boot sequence should notice when no network adapter
   has a good link-layer connection, and not bother running the DHCP

 - The initrd loads every single IDE driver with -k, and then tries to
   remove all the unnecessary ones later.  Since they were all loaded
   with -k, this fails.  (Debian's initrd has the exact same bug.
   Y'all at least seem to have made it not spew error messages while
   failing to remove them.)  It should either not use -k so that
   removal works, or better, it should figure out from PCI data which
   drivers are relevant, and only load those.

 - Sound does not work, except that mysteriously it starts working
   after a suspend/resume cycle.  (AC'97 sound chip, IIRC.)  In Debian
   it doesn't work at all.

 - I tried to use "su" and was prompted for the root password, which I
   did not know.  "sudo -s" worked, since I was successful in guessing
   that the password for the "ubuntu" user was "ubuntu".  I don't see
   why either of these users has a password at all on the livecd,

 - The only documentation on the livecd is for the installer, which is
   not particularly useful.  A README at top level, including all the
   stuff that's in the F1-F10 boot help screens, plus other useful
   info (such as the root password ;-) would be really nice.

Overall I'm pleased; I'm probably going to install Ubuntu just for the
working suspend-to-RAM.

[Please cc: me on replies - I am not subscribed to ubuntu-devel.]


More information about the ubuntu-devel mailing list