<div dir="ltr"><div dir="ltr"><div dir="ltr"><div dir="ltr"><div>Hi,<br></div><div><br></div><div>I'm running Linux Mint 19 with desktop Mate. I have some issues with environment modules. I have posted in the fora but no replies. Hence this mail.</div><div><br></div><div>1 The graphical login process does not read /etc/profile and therefore environment modules remain uninitialised. Took me a while to figure that out. I fixed it by directly sourcing /etc/profile.d/modules.sh  in ~/.bashrc. It would have been nice if the installation process had given me a hint. It would have saved some time. I also wonder if there is a way to tell the graphical login process to read /etc/profile. <br></div><div><br></div><div>2 When I enter the querie command "module avail" the response is repeated for the "out-of-the-box" modules but not for user modules in ~/privatemodules. The response is "double" also for some other commands. Other than that things seem to work. Is there some easy way to fix the double response?</div><div><br></div><div>For details see my post in the Mint fora:</div><div><a href="https://forums.linuxmint.com/viewtopic.php?f=47&t=279377">https://forums.linuxmint.com/viewtopic.php?f=47&t=279377</a></div><div><br></div><div>I have also posted in the Ubuntu fora but it does not say anything more but I'll give the URL anyway:</div><div><a href="https://ubuntuforums.org/showthread.php?t=2403458&p=13807805#post13807805">https://ubuntuforums.org/showthread.php?t=2403458&p=13807805#post13807805</a></div><div><br></div><div>Thank you beforehand for any help that you may give.</div><div><br></div><div>Kind regards,</div><div>Gösta Ljungdahl</div><div>Sundbyberg, Sweden<br></div><div><br></div><div><br></div></div></div></div></div>