libmgl install

fferrieu at gmail.com fferrieu at gmail.com
Sun Feb 7 16:59:25 UTC 2021


hi I am stuck with being unable to reinstall this library  and with the 
following report could you help?

Frederic

ubuntu 20.04 trying to reuse mathgl in C++ Netbeans env

/sudo apt install --reinstall libmgl-dev//
//Reading package lists... Done//
//Building dependency tree //
//Reading state information... Done//
//Some packages could not be installed. This may mean that you have//
//requested an impossible situation or if you are using the unstable//
//distribution that some required packages have not yet been created//
//or been moved out of Incoming.//
//The following information may help to resolve the situation://
//
//The following packages have unmet dependencies://
// libopenmpi3 : Depends: libfabric1 (>= 1.5.0) but it is not going to 
be installed//
//               Depends: libibverbs1 (>= 1.1.7) but it is not installable//
//               Depends: libpmix2 (>= 3.1.5) but it is not going to be 
installed//
//               Depends: libhwloc-plugins but it is not going to be 
installed//
//E: Unable to correct problems, you have held broken packages.//
//fred at thnkpadx1c4:~$ sudo apt purge libmgl-dev//
//Reading package lists... Done//
//Building dependency tree //
//Reading state information... Done//
//Package 'libmgl-dev' is not installed, so not removed//
//0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.//
//fred at thnkpadx1c4:~$ sudo apt install libmgl-dev//
//Reading package lists... Done//
//Building dependency tree //
//Reading state information... Done//
//Some packages could not be installed. This may mean that you have//
//requested an impossible situation or if you are using the unstable//
//distribution that some required packages have not yet been created//
//or been moved out of Incoming.//
//The following information may help to resolve the situation://
//
//The following packages have unmet dependencies://
// libopenmpi3 : Depends: libfabric1 (>= 1.5.0) but it is not going to 
be installed//
//               Depends: libibverbs1 (>= 1.1.7) but it is not installable//
//               Depends: libpmix2 (>= 3.1.5) but it is not going to be 
installed//
//               Depends: libhwloc-plugins but it is not going to be 
installed//
//E: Unable to correct problems, you have held broken packages./

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20210207/1609e9af/attachment.html>


More information about the Ubuntu-devel-discuss mailing list