surf 2.0+git20190208-2 — No sound output with Ubuntu LTS 20.04

Quentin Rameau quinq at
Wed Dec 2 18:41:06 UTC 2020

> Hi,

Hi Serge,

> This is to inform you that, unlike Ubuntu LTS 18.04, the web browser
> surf version 2.0+git20190208-2, installed from the standard Ubuntu
> package repository, no longer produces any sound on all web pages that
> were tried.

What was the last version which was working?

> Here is an example that previously worked with 18.04:
>     surf -m -a @

I tested this url on surf, firefox, chromium, and I don't get any sound
at all, could you explain what I have to do in order to start playing
some sound over-there?

On the other hand, I can play music with:

$ surf

(URL taken randomly on the internet looking for free-licensed sound)

But know that surf doesn't deal with sound support itself, it's
entirely handled by the gtk webkit port.

Usually a good first test in order to differenciate surf issues from
webkit issues is to make the same test with another webkitgtk-based
browser, like epiphany (and with others too is even better).

More information about the Ubuntu-devel-discuss mailing list