Kernel issues since -22

Christian Ehrhardt christian.ehrhardt at
Thu Jun 23 05:47:25 UTC 2016

I happened to own a W520 together with hundreds of coworkers in the past.
There seems to be a reoccurring HW defect on some of the boards regarding
voltage control.
About 10% of our devices (which already is a lot statistically) had the
issue you describe.

After a while we realized weird stuff, like if you once tried to boot
without AC plugged you are likely go into the black-boot issues and have to
reboot quite some times until it works again.
Since this matches closely what you describe in your state with -22 it
might be the same.

Back then, when it still bootet "sometimes" I was able to insert a few
things in the boot process and we realized that it still boots in the
background, but the graphic device wasn't seen on the pci bus.
Neither by nor by a lspci we inserted to write to disk. Now without a
graphic devices it couldn't show us much :-(

Given the raciness this issue had for us it is quite possible that slight
changes in the kernel initialization made it close to 100% to occur now.
The issue was bound to HW, so no reinstall or anything solved it for us -
one had a mainboard replacement which fixed it, but since nobody knows for
sure what it is I wouldn't count a 100% on that.

Christian Ehrhardt
Software Engineer, Ubuntu Server
Canonical Ltd

On Wed, Jun 22, 2016 at 10:06 PM, Nish Aravamudan <
nish.aravamudan at> wrote:

> On 22.06.2016 [12:43:46 -0700], Dale Amon wrote:
> > I have not got a whole lot of information because this happens
> > so early in the boot. Basically, no kernel since -22 works on
> > my Lenovo W520. If I were to hazard a guess, I would say it has
> > to do with some race condition in the systemctl set up. Even
> > in -22 I often must boot several times before it succeeds, although
> > the failures in it seem to be different.
> That seems buggy in and of itself. You're sure the hardware is stable?
> > Has anyone else reported similar show-stopper issues in
> > recent kernels?
> I would probably check the existing bugs and maybe file one.
> -Nish
> --
> Ubuntu-devel-discuss mailing list
> Ubuntu-devel-discuss at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ubuntu-devel-discuss mailing list