Support status of nginx in Ubuntu 14.04LTS expired in Feburary 2015?

Marc Deslauriers marc.deslauriers at canonical.com
Mon Apr 25 18:57:22 UTC 2016


Hi,

On 2016-04-25 02:45 PM, Andreas Wundsam wrote:
> Hello Ubuntu Maintainers,
> 
> I was surprised to see that ubuntu-support-status shows the support of package
> nginx expired in February 2015?
> 
> ---
> $ ubuntu-support-status --show-all
> [....]
> Supported until February 2015 (9m):
> [...] *nginx nginx-common *
> ---
> 
> apt show shows the package as being in main, but receiving only 9 months of support:
> 
> ---
> Supported: 9m
> APT-Sources: http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
> ----
> 
> So far, it has been my world view that packages that reside in the main
> repository would receive the full 5 years of LTS support.
> 
> What am I missing?
> 

Short answer: don't use ubuntu-support-status, it doesn't work.

Long answer: ubuntu-support-status is a deprecated tool that used to be used
when we had a 3y/5y split on desktop and server packages. It returns the
contents of the "Supported:" tag which hasn't been updated since Ubuntu 10.04
LTS. I've filed a bug to get it removed:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1574670

Marc.





More information about the Ubuntu-devel-discuss mailing list