Errors when building a kernel

Ralf Mardorf ralf.mardorf at
Fri Aug 21 09:05:41 UTC 2015


I try to build a kernel for Wily, that is as close as possible to a
kernel I use for Arch Linux. The reason is, that for the Arch install
Green drives don't run berserk and I anyway need a 3.x-rt.

I ensured that a Green drive stays asleep and copied the Arch Linux
kernel config to my Ubuntu install:

[root at archlinux rocketmouse]# t=10800;y=$(smartctl -A /dev/sdc|grep Lo|awk '{print $NF}');sleep $t;x=$(smartctl -A /dev/sdc|grep Lo|awk '{print $NF}');l=$(uname -r)_$(uname -m).$(printf $(cat /etc/issue));echo $l $x-$y=$((x-y)) spins in $(($t/60/60)) hours;zcat /proc/config.gz > /mnt/moonstudio/usr/src/config-$l
3.10.61-rt65-1-rt-lts_x86_64.Arch 15295-15294=1 spins in 3 hours

The only spin was caused by waking up the drive when running systemctl.

Then I tried to build the kernel [1] for
Ubuntu Wily Werewolf(development branch):

I used the Arch Linux config and edited

CONFIG_LOCALVERSION "-1-rt-lts" to "-1-moonstudio"

Since building the kernel failed, I also edited

CONFIG_DRM_I915=m and CONFIG_DRM_I915_KMS=y to "is not set"
CONFIG_R8187SE=m to "is not set"
CONFIG_RTL8192E=m to "is not set"
CONFIG_R8712U=m to "is not set"
CONFIG_WLAGS49_H2 to "is not set"
CONFIG_WLAGS49_H25=m to "is not set"

now I run into an issue. Building MPILIB fails, but I don't know what to
do, to disable or to build it.

I already tried to disable it by editing

CONFIG_MPILIB=m to "# CONFIG_MPILIB is not set" and CONFIG_KEYS‏=y to "is not set"

but after running "make oldconfig" it's back to CONFIG_MPILIB=m.

I tried with "CONFIG_MPILIB=n" and "CONFIG_KEYS=y".

Unfortunately it could take 1.5 hours before the next error occurs.

Is there a faster way to verify what modules will fail to build, instead
of compiling the kernel?

Fortunately "grep MPILIB .config" helps with the current issue.
It's still "CONFIG_MPILIB=m" after running "make oldconfig". How can I
find out what settings I need to edit?

The Internet wasn't helpful :(.

[root at moonstudio src]# export CONCURRENCY_LEVEL=2;wget && tar zxf linux-3.10.61.tar.gz && mv linux-3.10.61 linux-3.10.61-rt65 && cd linux-3.10.61-rt65 && gzip -dc ../patch-3.10.61-rt65.patch.gz | patch -p1 && cp ../config-3.10.61-rt65-1-rt-lts_x86_64.Arch .config && make oldconfig && make oldconfig && date && make-kpkg clean && make-kpkg --initrd kernel-image kernel-headers && make-kpkg clean && date


PS: Usually when building an Ubuntu kernel, I don't use an Arch Linux
config. I try to do it regarding

to ensure that it's not related to the kernel.

More information about the Ubuntu-devel-discuss mailing list