trouble building (linking) code on Xubuntu

Evan Huus eapache at gmail.com
Tue May 29 13:10:10 UTC 2012


I'm going to take a guess that the build system is looking for
libraries in the old locations, rather than the new multiarch
locations. Try playing around with -L options to the linker (possibly
missing "/lib/x86_64-linux-gnu")?

Evan

On Tue, May 29, 2012 at 8:58 AM, John Gabriele <jmg3000 at gmail.com> wrote:
> Hi,
>
> Not sure if this is the right place to ask about this. Please let me
> know if I should be asking this elsewhere.
>
> I'm trying to build the most recent version of
> [ne](http://ne.dsi.unimi.it/) (the "nice editor") on Xubuntu 12.04.
> The source files seem to compile fine, but then when I get to the link
> stage, I get this:
>
> ~~~
> {...snip various files getting successfully compiled, ... then}
>
> cc -lm    actions.o ansi.o autocomp.o buffer.o clips.o cm.o command.o
> display.o edit.o errors.o exec.o ext.o hash.o help.o input.o
> inputclass.o keys.o menu.o names.o navigation.o ne.o prefs.o regex.o
> request.o search.o signals.o streams.o support.o syn_hash.o
> syn_regex.o syn_utf8.o syn_utils.o syntax.o term.o undo.o utf8.o -
> lcurses -o ne
> menu.o: In function `draw_status_bar':
> menu.c:(.text+0x1416): undefined reference to `floor'
> menu.c:(.text+0x15c1): undefined reference to `floor'
> collect2: ld returned 1 exit status
> make[1]: *** [ne] Error 1
> make[1]: Leaving directory `/home/john/opt/src/ne-2.4/src'
> make: *** [install] Error 2
> ~~~
>
> (If it matters, this is on a 64-bit machine.)
>
> As an aside, if I go ahead and install ne via apt-get (which gets me
> the older ne version 2.3.1), I see this:
>
> ~~~
> $ ldd `which ne`
>        linux-vdso.so.1 =>  (0x00007fff76fff000)
>        libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5
> (0x00007f29b7416000)
>        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f29b711c000)
>        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f29b6d5e000)
>        /lib64/ld-linux-x86-64.so.2 (0x00007f29b7650000)
> ~~~
>
> Any suggestions as to what might be the problem?
>
> Thanks,
> ---John
>
> --
> Ubuntu-devel-discuss mailing list
> Ubuntu-devel-discuss at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss



More information about the Ubuntu-devel-discuss mailing list