udev ignore_device removed why?

pere lengo perelengo at hotmail.com
Thu Nov 18 19:55:17 UTC 2010

i'm trying to use a guillemot corp. Hercules DJ peripherial in a vmware virtual machine running on ubuntu lucid 10.0.4. amd64
To be able to use it in vmware I have to disconnect it from usbhid.
I've tried to make a rule for udev, but it doesn't work because in version 10.0.4 the OPTION ignore_device has been removed.
I've tried to disconnect peripherial from ushdid doing (usb plugged in 4-2:1.0)

cd /sys/bus/usb/drivers/usbhid
echo '4-2:1.0' >unbind 

then it disconnects from usbhid
and then i go to vmware and select to connect the device to the virtual machine, and vmware does not alert that the device is being used by another 
driver (usbhid), ok,  but then udev remounts the device automatically.

I think it wouldn't happen if ignore_device was still an available OPTION, writting this rule:

ATTRS{idVendor}=="06f8",  OPTIONS+="ignore_device"
ATTR{idVendor}=="06f8",  OPTIONS+="ignore_device"

What can I do to disconnect the device and avoid udev mounts the device?

Would next udev version allow to use ignore_device??
Is there any patch to reactivate this functionality?

Pere Joseph
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20101118/2e7d90da/attachment.html>

More information about the Ubuntu-devel-discuss mailing list