idjc doesn`t work with voip since karmic

Daniel Chen seven.steps at
Thu Feb 11 11:43:32 UTC 2010

On Mon, Feb 8, 2010 at 8:33 AM, Ralf Eleven <ralf11 at> wrote:
> The voip-function in idjc doesn't work.
> It should work like this:

This approach will fail because j-a-c-k has not been repromoted to
main yet, and thus alsa-plugins cannot be compiled with j-a-c-k
support and is missing the plugin.

> But since Ubuntu karmic, which works with pulseaudio, and also since
> Debian squeeze there are no ~/.asoundrc files, because there is no
> program "asoundconf" in the packet alsa-utils.

There is not an ~/.asoundrc by default /ever/. It's a user-created
file (whether by hand or by some utility). asoundconf is no longer
maintained and was removed from the alsa-utils source package, but one
can always construct an asoundrc by hand.

The bit about PulseAudio is not really relevant; the real cause is due
to missing j-a-c-k in main, so PulseAudio cannot be compiled with
j-a-c-k support, etc. Even if j-a-c-k is available in main, you'd
still need to configure PulseAudio to use j-a-c-k.

(There are unofficial packages that have j-a-c-k support, but they
should be unnecessary for Lucid.)

> I also tried to delate pulseaudio and to install asoundconf from older
> sources manually, but first it wouldn't be a nice way and second it also
> doesn't worked.

Again, PulseAudio really isn't the cause here but suffers indirectly.

> If pulseaudio is the soundserver of the future, how to work with voip in
> idjc and how to record voip?

Help get j-a-c-k back into main.


More information about the Ubuntu-devel-discuss mailing list