Apache2 in default Ubuntu install

Evan eapache at gmail.com
Fri Aug 13 20:21:32 BST 2010


On Fri, Aug 13, 2010 at 3:05 PM, Louis Simard <louis.simard at gmail.com> wrote:
> At 2010-08-13 08:39 GMT, Joshua Timberman <joshua at opscode.com> wrote:
>> Hello!
>>
>> On Aug 13, 2010, at 12:37 AM, Micah Gersten wrote:
>>
>>> Because sensible defaults are necessary.  You get your choice of Apache
>>> or something else.  If you selected another httpd on install and php5
>>> dragged in apache, that might qualify as a bug.  If you selected
>>> nothing, well you get the sensible default which is Apache.
>>
>>
>> Why not have the depends something like:
>>
>> Depends: ... apache2 | lighthttpd | nginx | otherhttpserverphpworkswith ...
>>
>> So that if one of the others is installed, php5 doesn't try to install apache2?
>>
>> --
>> Opscode, Inc
>> Joshua Timberman, Technical Evangelist
>> C: 720.334.RUBY E: joshua at opscode.com
>>
>>
>> --
>> Ubuntu-devel-discuss mailing list
>> Ubuntu-devel-discuss at lists.ubuntu.com
>> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel-discuss
>
> Or, perhaps more future-proof, have php5-cgi "Depend" on a new virtual
> package called http-server or something, and make
> apache/nginx/lighttpd/... "Provide" http-server.
>
> However, I don't know how one would go about making the php5-cgi
> package install the proper library (like libapache2-mod-php5) for the
> specific httpd that's actually installed, upon installing php5-cgi
> itself... except via Suggests/Recommends + the user opting to install
> the proper one afterwards :)

What would really be useful here would be some sort
of dpkg co-depends field. So php5 co-depends on
apache-mod-php with apache, it co-depends on lighttpd-php
(or whatever the package is) with lighttpd, etc.

Probably too complex to ever get into Debian, but an
interesting idea none-the-less.

Evan



More information about the Ubuntu-devel-discuss mailing list