Various Problems with Keybindings in Lucid (beta 2)

Philipp Schaefer philipp.schaefer at
Mon Apr 19 13:44:55 UTC 2010

Hi all,

while trying the 10.04 beta 2 I encountered the following bugs all
related to keybindings.

I always used the Super(Win) keys to start a terminal (just the Super
key for it self). I wanted to do that again, by changing the relevant
entry in the Keyboard Shortcuts dialog. This didn't work because the
keys now seem to be bound to mod4 by default. So far that shouldn't be
the problem, because one can change the behaviour of the Win keys in the
Options dialog under Preferences -> Keyboard -> Layout. But whatever I
tried to choose there, the Win keys remained being bound to mod4. A look
at xmodmap confirmed that.

Now I used xmodmap itself to change it (i.e. remove Super_L from the
mod4 list) which allowed me to configure everything as desired, as well
as successfully changing the Win key behaviour in the above mentioned
Options dialog, if I tried to (not that I needed that anymore).

Now after having played with xmodmap in that way Indicator Applet and
Indicator Applet Session developed unbearable behaviour in that they
'captured' the m and s key, respectively. Whenever I pressed m anywhere
the Menu of the former Applet pop up and the same happened with s and
the later. So now I have both applets removed from the panel, which
obviously isn't a desirable solution.

I include the output of xmodmap and cat .xmodmaprc:

xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
control     Control_L (0x25),  Control_R (0x69)
mod1        Alt_L (0x40),  Alt_R (0x6c),  Meta_L (0xcd)
mod2        Num_Lock (0x4d)
mod5        ISO_Level3_Shift (0x5c),  Mode_switch (0xcb)

clear lock
clear mod4
keycode 66 = Mode_switch
keysym a = a A adiaeresis Adiaeresis
keysym o = o O odiaeresis Odiaeresis
keysym u = u U udiaeresis Udiaeresis
keysym s = s S ssharp
keysym e = e E EuroSign



More information about the Ubuntu-devel-discuss mailing list