Report on Successful E17 installation from latest pkg-e debian repository

eye zak eye.zak.devel at gmail.com
Mon May 18 18:58:03 BST 2009


Hi,

Sorry, my first post got cut off, it's on the list archive.  John
Vivirito was correct, I wanted the supporting packages.

We don't need libeet, because that's in experimental with the other
pkg-e stuff. I didn't have karmic-updates and karmic-security repos so
now i have

I am running it on Jaunty now, with karmic repos (good, but a few
bugs, integrates with gdm). I needed to add both testing and
experimental debian repos, so if we can get the testing stuff in it
will integrate well from a mirror.

According to my package manager as of now (repos: karmic, jaunty and
debian testing) I need these support packages for binary compatibility
with the debian pkg-e repo:

libgcrypt11 (>= 1.4.4-2)
libgpg-error0 (>= 1.6-1)

That's it, so we're close.  Then put all the pkg-e stuff in a mirror
(eet is in that so it's ok) and it will be simple to install and
maintain alongside a standard karmic desktop.

Isaac Gordezky

On Mon, May 18, 2009 at 11:28 AM, Albin Tonnerre <lutin at ubuntu.com> wrote:
> On Sun, May 17, 2009 at 07:21:26PM -0400, eye zak wrote :
>> Hi all,
>
> Hello,
>
>> I would like to make some requests for specific packages to be updated
>> from the debian repositories to allow for the installation of the
>> pkg-e team's e17 on the upcoming karmic release.  E17 can be
>> successfully installed beside gnome/kde in ubuntu if the following
>> packages are retrieved from the debian repositories (testing and
>> experimental):
>
>> If any of these could be included in the karmic release, it would be
>> trivial to add e17 support to Ubuntu.  Let me know if i can do
>> anything to help, I have some packaging experience.
>
> With my e17-related stuff Debian maintainer hat, I disagree here.
>
> Although it is becoming more and more usable/stable, I don't think it is
> suitable for upload to a stable release for the moment. Library interfaces
> change often, making it hard to backport bugfixes or provide minor updates to
> these components.
>
> Regards,
> --
> Albin Tonnerre
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iQIcBAEBCAAGBQJKEX6HAAoJEBEG8gBbtuSlEBwQAMMJmqwjAPlb11PtdvxDMHl6
> 9tmU0nbQB3ykpn+K9BkqIvO60xF4AfwUDcnQ3E+PYJ4mNoKOwXaFfuzJWeZimMDw
> fVO8eC8drenaF+FePIRSV99micjurWui9ADZMbwHBxS2s2Fz9X6uA67emGAMmhAu
> wu74+UAaDQLgZnDqp/5sQBhbtSCrWdFeHy9D9z7JjPtsflU9FauISjCregZCM2F0
> v/JtAYEtNYWx5dEzFtMoHZIwojhL7l9uS8Pwi0AkGX8uNV14WC4GkJAKXefXUrWL
> OddrDkHJYkM8l47uX3ZjmSgpHgUxZxH8WF01ynES7pN2n0Siv90Zwz1MwaUEHePA
> hdVeUpNai1tEoeDAC8By4wLwD1c4gUknoBB8iMQFSn355BdU7p1HX8uOLVEoCLO4
> NZhzvwDTbK2ZypOEKe04mYhKe8z9addjJKXa0pB916ori4CssZe6z6b8tkmffEV4
> jAGXO6xB9eXgc6jhCk4RzDoVB3LZsUfUcY9LbM2BFH05MaS8f8kdX5ATMYw3EyKQ
> 7SX8FvJuOog4iZewgDk2UL+7pJGvfv7eJOfnzyvVji4v7gjv0dIl8nI0m+xC9F3Y
> jgee3eL9ssSyVykOQPIMuL3NEMZb1/IVhQrlpcJYG6LHuF2YpF8zLW9scsQnxvAk
> MCo16UjmfP2fSQEBq6te
> =+2K1
> -----END PGP SIGNATURE-----
>
>



More information about the Ubuntu-devel-discuss mailing list