Opal VoIP

Antonio projektname.toni at googlemail.com
Mon Apr 20 23:41:02 BST 2009


Hi!

I wanna use Opal but on compiling I get error messages
with "PAtomicInteger".

In the FAQ's of Opal I found this:

--------------------------
How do I fix gcc errors about "PAtomicInteger" when compiling OPAL?

This error is usually indicates the presence of two incompatible 
versions of the PTLib headers, and that the OPAL build process is 
detecting the wrong set which is probably located in /usr/local/include 
or /usr/include (check the configure output to be sure)

The easiest way to solve the problem is to set the PWLIBDIR environment 
to point to the correct version of PTLib. Alternatively, deinstall the 
incorrect version so that the auto-detection find the correct version.
--------------------------

I only installed libopal-dev with its dependencies.
What can I do?


Best regards

Antonio






More information about the Ubuntu-devel-discuss mailing list