Problem with yum etc after installing Ubuntu 7.10.....

Christopher Halse Rogers chalserogers at
Thu May 15 05:14:42 UTC 2008

On 5/15/08, Peter Teoh <htmldeveloper at> wrote:
> a.  install ubuntu
>  b.  apt-get install yum*
>  c.  apt-get install git

This probably hasn't installed the program you thought it would.  It
turns out that before Linus developed the distributed VCS called 'git'
there was already a project called the 'GNU interactive tools', or
'git'.  This is what the 'git' package contains.  You actually wanted
to install the 'git-core' package, which contains the dvcs.

>  Next I tried "git", I got "command not found", but reattempted to
>  "apt-get install git" will give me:
>  root at oracledaddy:/tmp# apt-get install git
>  Reading package lists... Done
>  Building dependency tree
>  Reading state information... Done
>  git is already the newest version.
>  0 upgraded, 0 newly installed, 0 to remove and 211 not upgraded.
>  I tried to yum install some other stuff, I got the following:
>  There was a problem importing one of the Python modules
>  required to run yum. The error leading to this problem was:
>   No module named cElementTree
This seems like the package misses a dependency.  That should be
documented in a bug filed against the package on  On
the other hand, I'm don't think that installing programs through yum
is a good idea on an Ubuntu system.  I may be wrong here, though.  Why
do we even have that package? :)

More information about the Ubuntu-devel-discuss mailing list