tracking down suspend/hibernate bugs?

Paul S paulatgm at
Tue Jan 15 02:17:29 UTC 2008

Paul S said the following on 01/14/2008 08:17 PM:
> Still no idea why kde-power-manager can't start a suspend....

Here's an idea .. maybe some of the old acpi-support suspend is still 
active.  I just tried adding a logger line to 
/usr/lib/hal/scripts/linux/hal-system-power-suspend-linux to print out 
the $QUIRKS:

# We only support pm-utils
if [ -x "/usr/sbin/pm-suspend" ] ; then
    logger "pm-suspend quirks are $QUIRKS"
         /usr/sbin/pm-suspend $QUIRKS

Since kde-power-manager won't work and my usb keyboard sleep button 
doesn't work, I tried the Fn-Esc key combo on the laptop, which is the 
suspend key combo.  The laptop suspended and resumed fine.  Now, when I 
look at /var/log/messages, there is no line from the logger that I 
inserted above.  Also, when I look at /var/log/pm-suspend.log, it never 
changed from the previous suspend.  So, it appears something else is 
functioning to suspend, other than pm-utils via hal.

I did an upgrade from gutsy.  Maybe my system still has something 
installed that it shouldn't.  If you want, I could probably do a fresh 
install from hardy alpha 3 .. let me know if you think it's necessary.


More information about the Ubuntu-devel-discuss mailing list