Error: BrokenCount > 0

shirish shirishag75 at
Sun Dec 21 04:50:52 UTC 2008

Hi all,
Sorry in advance because this is going to be a long post as had some
strange experience and want to share the same with everybody.

I had errors in my filesystem today. Hence put up a live CD and ran
fsck on that partition.

The filesystem is an ext3 system.

$ sudo fsck -y /dev/sdb5

The partition is where my / partition lies.

I have

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x48254824

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          18      144553+  83  Linux
/dev/sdb2              19       19457   156143767+   5  Extended
/dev/sdb5              19        2450    19535008+  83  Linux
/dev/sdb6            2451        2574      995998+  82  Linux swap / Solaris
/dev/sdb7            2575       19457   135612666   83  Linux

/dev/sdb7 is my /home partition.

It took some time and removed some stuff but was able to log in.

For a long time the update-manager showed Error: BrokenCount > 0

Looked at the documentation

and tried

$ sudo apt-get check

and got the following information.

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  gnome-app-install: Depends:  but it is not installed
                     Depends:  but it is not installed
  onboard: Depends:  but it is not installed
  penguintv: Depends:  but it is not installed
  python-gnome2: Depends:  but it is not installed
  update-manager: Depends:  but it is not installed
E: Unmet dependencies. Try using -f.

Then tried both synaptic as well as the CLI and got the following output :-

~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:

Suggested packages:
  python-gconf-dbg python-gnome2-extras-doc
The following NEW packages will be installed:

0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/99.9kB of archives.
After this operation, 406kB of additional disk space will be used.
Do you want to continue [Y/n]? Y

Traceback (most recent call last):
  File "/usr/bin/apt-listchanges", line 227, in <module>
  File "/usr/bin/apt-listchanges", line 48, in main
    debs = apt_listchanges.read_apt_pipeline(config)
  File "/usr/share/apt-listchanges/", line 64, in
    (pkgname, oldversion, compare, newversion, filename) = pkgline.split()
ValueError: need more than 4 values to unpack

(Reading database ... 127778 files and directories currently installed.)
Preparing to replace python-gconf 2.22.3-0ubuntu1 (using
.../_2.22.3-0ubuntu1_i386.deb) ...
Unpacking replacement python-gconf ...
Preparing to replace python-gtkhtml2 2.19.1-0ubuntu11 (using
.../_2.19.1-0ubuntu11_i386.deb) ...
Unpacking replacement python-gtkhtml2 ...
Processing triggers for python-support ...
Package  listed more than once, only processing once.
dpkg: error processing  (--configure):
 no package named `' is installed, cannot configure
Errors were encountered while processing:

E: Sub-process /usr/bin/dpkg returned an error code (1)

Even doing an update/safe-upgrade at that point in time didn't resolve
the issue.

I did do an aptitude autoclean so if there's any left-over stuff it
would get removed.

Tried again and again but it wouldn't get configured.

12 hours later and another round of update and upgrades and this time
it configures it
without an issue.

Now I'm preplexed and have few questions on few counts.

a. Was the procedure I tried correct or not?
b. Whenever I run an fsck from the CD wouldn't it be nice if it would
put up the log of the same at the partition which one just fscked.
c. Why it didn't work the first time around but worked later.
In-between there hasn't been any shutdown or anything.
d. If I wanted to file a bug-report on this behavior where or which
package/packages should I file bugs under?

Feel free to comment,suggest whatever you feel.
          Shirish Agarwal
  This email is licensed under
065C 6D79 A68C E7EA 52B3  8D70 950D 53FB 729A 8B17

More information about the Ubuntu-devel-discuss mailing list