Unmounting SSHFS

Chris Coulson chrisccoulson at googlemail.com
Tue Dec 2 21:56:20 UTC 2008

On Tue, 2008-12-02 at 12:46 -0700, Aaron Toponce wrote:
> Chris Coulson wrote:
> > I can unmount a SSHFS volume without being root. How are you trying to
> > do it?
> I wasn't aware of fuserumount, but I was using the GUI- right-clicking
> the mounted icon on my desktop, and choosing "Unmount volume". The
> "umount" command also fails, although succeeds on removable media.
I can recreate the behaviour you see by right-clicking on the desktop
icon. The error I see is "umount: /media/home is not in the fstab (and
you are not root)", which is the same error I see when running "umount"
from the command line.

I ran umount through strace, and it tries to execute the helper
"/sbin/umount.fuse.sshfs" to unmount the volume, but this doesn't exist.

Perhaps this is a bug in util-linux.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20081202/a7d57630/attachment.sig>

More information about the Ubuntu-devel-discuss mailing list