Thoughts about EXT4 optional in Jaunty Development & questions about Plymouth

Chris Jones chrisjones at
Mon Dec 1 23:58:34 UTC 2008

Message: 2
Date: Wed, 26 Nov 2008 10:01:03 +0000
From: Matthew Paul Thomas <mpt at>
Subject: Re: Thoughts about EXT4 optional in Jaunty Development &
        questions       about Plymouth
To: ubuntu-devel-discuss Dev <ubuntu-devel-discuss at>
Message-ID: <355b967ee3bbb41cb9997ac65cc2e063 at>
Content-Type: text/plain; charset="us-ascii"

On Nov 24, 2008, at 12:07 AM, Dean Loros wrote:
> ...
> There has been talk in the testing group about Plymouth & possible
> replacement of Usplash...IMO Plymouth provides a better user
> due to a "more" seamless blending of Grub, Kernel boot & GDM. I
> that there could be "issues" with this, but it could also net a more
> positive user experience .
> ...

Plymouth is scheduled for discussion at the Ubuntu Developer Summit two 
weeks from now. 

Matthew Paul Thomas


Just thought it was worth mentioning that it's certainly possible to use
ext4 on Ubuntu already. I'm using it for my 2 data hard drives which
were originally ext3. But ext4 is backward compatible and therefore has
the capability to mount ext3 partitions and ext4.

Here's what I done (as I posted in a recent forum):

First you have to enable the system to mount ext4 because Ubuntu still
flags ext4 file system as experimental as is therefore disabled by

ubuntu% sudo tune2fs -E test_fs /dev/your_drive_partition

And then you simply have to mount the drive.

ubuntu% sudo mount /dev/your_drive_partition -t ext4dev /media/your_mount_directory


A quick check with df to see if it worked.

ubuntu% df -T

It worked. Here's what mine looks like. The last 2 entries are the ext4
mounts. You'll notice that they are flagged as ext4dev, that's because
(as mentioned) Ubuntu still flags ext4 as experimental, even though it's

ubuntu% df -T
Filesystem Type   1K-blocks Used Available Use% Mounted on
/dev/sda6      jfs    17549600   4258296  13291304  25% /
tmpfs        tmpfs      250364         0    250364   0% /lib/init/rw
varrun       tmpfs      250364       324    250040   1% /var/run
varlock      tmpfs      250364         0    250364   0% /var/lock
udev         tmpfs      250364      2872    247492   2% /dev
tmpfs        tmpfs      250364         0    250364   0% /dev/shm
lrm          tmpfs      250364      2380    247984   1% /lib/modules/2.6.27-7-generic/volatile
/dev/sda1      jfs      495712     13176    482536   3% /boot
/dev/sda5     ext2    55599836  25436932  27903524  48% /home
/dev/sdb1  ext4dev   157566568  45810908 103751680  31% /home/chris/disk
/dev/sdc1  ext4dev   307663800 256501836  35778776  88% /home/chris/disk-1

For the record too, it's definitely snappier with both read/write on the
simple real world tests that I done.


Chris Jones <chrisjones at>

More information about the Ubuntu-devel-discuss mailing list