Problems with SELinux

(=?utf-8?q?=60=60-=5F-=C2=B4=C2=B4?=) -- Fernando ubuntu at
Wed Apr 9 22:33:37 UTC 2008

On Monday 07 April 2008 17:41:20 Marc Baas wrote:
> Dear all,
> Since I don't know where else to put this problem I ran into and I
> cannot specify it clearly enough to file a bug report, I'm sending it to
> this mail group.
> I've been testing Hardy since early alpha 6. I also tried installing
> SELinux according to the specifications of the Ubuntu SELinux wiki (run
> sudo apt-get install selinux) and it worked flawlessly for me at the
> time.
> Today I tried it again on a current up to date beta of hardy. I call it
> a clean install since I haven't manually changed anything and have only
> installed packages with apt that I normally do by default through a
> script, to not have to do everything manually.
> This time however, after rebooting and having the labeling finish, I was
> welcomed with a message telling me HAL failed to initialize. On top of
> that, while it was first loading, the whole gnome menu disappeared and
> left me with nothing but an empty desktop. Immagine Alt+F2 didn't work
> either.
> I managed to work around this and get a terminal going, tried to restart
> HAL, but got permission errors from SELinux telling me that this user
> was not allowed to...., etc.
> Needless to say, lots of things were not working (at some point even my
> ethernet adapter was blocked) and in the end, I removed SELinux in order
> to be able to use my system. Hence I don't have all the detailed info
> one could wish for in order to file a bug report.
> Due to lack of time and wanting to be sure things would run properly I
> went ahead and did a reinstall.
> As a result of this I'm under the impression that the policies that came
> with alpha 6, which worked fine for me, must have been changed one way
> or another and now don't work for me anymore.
> Is this something that can be confirmed by the ones that are working on
> the implementation of SELinux?
> Together with that, when can we expect configuration tools for SELinux
> like the ones one finds in Fedora? It really is very user unfriendly and
> complex to work with SELinux and try to configure it with the tools, let
> alone without those.
> Thanks in advance for your time and attention.
> Marc

Yesterday was not the best of days to do updates.
Today my system is feeling better. I guess yours is too!

BUGabundo  :o)
Linux user #443786    GPG key 1024D/A1784EBB
My new micro-blog @
ps. My emails tend to sound authority and aggressive. I'm sorry in advance. I'll try to be more assertive as time goes by...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the Ubuntu-devel-discuss mailing list