Help with Gutsy Upgrade

Rick Knight rick_knight at
Tue Apr 1 15:42:08 UTC 2008

Ubuntu developers. I know this is not the place for the usual requests 
for help with Ubuntu, but I don't know where else to look. I've posted 
to the Ubuntu-users list, the Ubuntu and Kubuntu forums and I've be 
visited both #ubuntu and #kubuntu on IRC. I've even added my comment to 
a Launchpad bug report, #190588. I've gotten several suggestions to fix 
my problem, but so far none of them have made a difference. I've also 
tried to post to ubuntu-devel, but the moderator refused the post and 
recommended I post here instead.

About 2 weeks ago I tried to upgrade my PC using the instructions found 
here The upgrade 
froze at Installing packages 2%. After a couple of hours I stopped the 
upgrade process and tried again. This time the upgrade finished 
successfully. I rebooted the PC expecting to get a new Gutsy desktop, 
but instead got the Busy Box initramfs prompt and this message...

Check root= bootarg cat /proc/cmdline or missing modules, devices: cat 
/proc/modules ls /dev

ALERT! /dev/disk/by-uuid/(my boot disk uuid) does not exist. Dropping to 
a shell.

All modules seem to be present and loaded but "ls /dev/disk/by-uuid" 
shows I have no hard drives (I actually have 2 hard drives, both EIDE 
devices, not SATA).

I can boot using the prior Feisty 2.6.20-16-generic kernel and am able 
to trouble shoot using the older kernel. As I said above, I have tried 
several suggestions to fix this problem, but so far none have had any 

I've tried re-installing the 2.6.22-14-generic kernel.
I've tried modifying initramfs.
I've re-installed and updated GRUB.
I've modified GRUB's menu.lst to use /dev/sd and /dev/hd drive identifiers.
I've tried to re-run the upgrade, both form the internet and from the 
alternate CD, but both methods say my system is up to date and can't be 

I don't know if this may be important information, but when I upgraded 
from Dapper to Feisty my system refused to recognize the new /dev/sd 
drive identifiers and I had to modify GRUB and /etc/fstab to use /dev/hd 
instead, but that didn't work this time.

While this may not be a common problem with the Feisty / Gutsy upgrade, 
a Google search shows the several are have the same or similar upgrade 

Can someone here please give me some suggestions to fix this problem?

Rick Knight

More information about the Ubuntu-devel-discuss mailing list