[Bug 1378188] Re: [GNOME3 Staging PPA] strange shadow rendered where client-side decorations are used

Robert Ancell robert.ancell at canonical.com
Sun Feb 1 20:44:37 UTC 2015


** Description changed:

- When using apps where client-side decorations are being used, a strange
- shadow render appears below the window. Screenshots are attached. If
- CSDs are not being used, then shadows are rendered correctly.
+ [Impact]
+ The Intel video driver has a bug that can cause to incorrectly draw certain trapezoids. This is visible when using client side decorations in GNOME 3 (see attached screenshots).
  
- WORKAROUND: Remove the GNOME3 Staging PPA.
+ [Test Case]
+ Run GNOME 3 with client side decorations on Intel hardware.
+ Observed result:
+ Shadow under window is missing corners.
+ Expected result:
+ Shadow looks correct.
  
- ProblemType: Bug
- DistroRelease: Ubuntu 14.10
- Package: mutter 3.14.0-1ubuntu1~utopic1 [origin: LP-PPA-gnome3-team-gnome3-staging]
- ProcVersionSignature: Ubuntu 3.16.0-20.27-generic 3.16.3
- Uname: Linux 3.16.0-20-generic x86_64
- ApportVersion: 2.14.7-0ubuntu3
- Architecture: amd64
- CurrentDesktop: GNOME
- Date: Mon Oct  6 22:50:17 2014
- InstallationDate: Installed on 2014-06-13 (115 days ago)
- InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
- ProcEnviron:
-  TERM=xterm
-  PATH=(custom, no user)
-  XDG_RUNTIME_DIR=<set>
-  LANG=en_US.UTF-8
-  SHELL=/bin/bash
- SourcePackage: mutter
- UpgradeStatus: Upgraded to utopic on 2014-10-03 (3 days ago)
- ---
- ApportVersion: 2.14.7-0ubuntu8
- Architecture: amd64
- CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
- CompositorRunning: None
- CurrentDesktop: GNOME
- DistUpgraded: 2014-10-03 08:48:19,347 DEBUG enabling apt cron job
- DistroCodename: utopic
- DistroRelease: Ubuntu 14.10
- DistroVariant: ubuntu
- DkmsStatus:
-  vboxhost, 4.3.16, 3.13.0-35-generic, x86_64: installed
-  vboxhost, 4.3.16, 3.16.0-20-generic, x86_64: installed
-  vboxhost, 4.3.16, 3.16.0-21-generic, x86_64: installed
-  vboxhost, 4.3.16, 3.16.0-25-generic, x86_64: installed
- ExtraDebuggingInterest: Yes, if not too technical
- GraphicsCard:
-  Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display [8086:0f31] (rev 0c) (prog-if 00 [VGA controller])
-    Subsystem: Acer Incorporated [ALI] Device [1025:0845]
- InstallationDate: Installed on 2014-06-13 (171 days ago)
- InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
- MachineType: Acer E1-510P
- Package: xorg 1:7.7+7ubuntu2
- PackageArchitecture: amd64
- ProcEnviron:
-  TERM=xterm
-  PATH=(custom, no user)
-  XDG_RUNTIME_DIR=<set>
-  LANG=en_US.UTF-8
-  SHELL=/bin/bash
- ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-25-generic.efi.signed root=UUID=87cb643d-4e85-4be4-9864-0e13b0ed0382 ro quiet splash acpi_osi=Linux i915.invert_brightness=1 vt.handoff=7
- ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
- Tags: third-party-packages utopic gnome3-ppa ubuntu
- Uname: Linux 3.16.0-25-generic x86_64
- UpgradeStatus: Upgraded to utopic on 2014-10-03 (59 days ago)
- UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo vboxusers
- _MarkForUpload: True
- dmi.bios.date: 04/07/2014
- dmi.bios.vendor: Acer
- dmi.bios.version: V2.11
- dmi.board.name: E1-510P
- dmi.board.vendor: Acer
- dmi.board.version: V2.11
- dmi.chassis.type: 10
- dmi.chassis.vendor: Acer
- dmi.chassis.version: Chassis Version
- dmi.modalias: dmi:bvnAcer:bvrV2.11:bd04/07/2014:svnAcer:pnE1-510P:pvrV2.11:rvnAcer:rnE1-510P:rvrV2.11:cvnAcer:ct10:cvrChassisVersion:
- dmi.product.name: E1-510P
- dmi.product.version: V2.11
- dmi.sys.vendor: Acer
- version.compiz: compiz N/A
- version.ia32-libs: ia32-libs N/A
- version.libdrm2: libdrm2 2.4.56-1
- version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu3
- version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
- version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu3
- version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
- version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
- version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
- version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu4.1
- version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
- xserver.bootTime: Mon Dec  1 22:16:33 2014
- xserver.configfile: default
- xserver.errors:
- 
- xserver.logfile: /var/log/Xorg.0.log
- xserver.outputs:
-  product id                                4588
-  vendor                                     AUO
- xserver.version: 2:1.16.0-1ubuntu1
+ [Regression potential]
+ Low. The fix is from upstream and just changes the logic error in the CompositeTrapezoids routine.

-- 
You received this bug notification because you are a member of GNOME3
Team, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1378188

Title:
  [GNOME3 Staging PPA] strange shadow rendered where client-side
  decorations are used

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1378188/+subscriptions



More information about the ubuntu-desktop mailing list