Lionel Dricot (aka Ploum) zeploum at
Sat Nov 5 04:00:00 CST 2005

Hello desktop hackers,

I reported the bug #3204 (
) a few weeks ago.

I was not too woried about it but it seems that this bug is more
widespread than I tought and many many websites are not usable when
you have this bug.
I even heard around me people reinstalling a Windows in dual-boot to
surf on such websites. That's too much for me, I want to found a fix
or a workaround.

Unfortunatly, I'm not aware of how the font system is working under Ubuntu.

All I know, for now is that :

- The bug is not really against the flash plugin package. Even
desinstalling it and installing flash within firefox does not solve
the problem.

- For most people, installing gsfonts-x11 and mstcorefonts solve the
problem. But if those packages were already installed, it's like Flash
doesn't found it. (trying to reinstall them without success).

I've tried to rebuild the fontconfig-cache (  sudo fc-cache -f -v )
without success. I'm not even sure that Flash use fontconfig.

I've also found that a fc-match "something" always returns me Vera.ttf:
fc-match Comic
Vera.ttf: "Bitstream Vera Sans" "Roman

with some exceptions :
 ~% fc-match Verdana
Verdana.ttf: "Verdana" "Regular"
~% fc-match Courier
cour.pfa: "Courier" "Regular"
~% fc-match Times
VeraSe.ttf: "Bitstream Vera Serif" "Roman"

So, anyone can point me to some documentation or to a fonts guru so I
can try to understand and solve this problem?
It's very frustrating and I feel the "so simple solution" just at the
end of my fingers. I will not sleep anymore until this is solved ;-)

Thank you for any help regarding this,


PS : the good news is that, on wednesday, in our install party, we
installed nearly 80 Ubuntu systems :-)

More information about the ubuntu-desktop mailing list