Hardy: Festplattenspiegelung

Rainer spots4as at gmx.de
Don Mar 5 07:57:02 GMT 2009


Hallo zusammen,

dem Problem bin ich inzwischen wohl auf der Spur, weiß aber keine
Lösung.

Am Wed, 4 Mar 2009 21:59:25 +0100
schrieb Rainer <spots4as at gmx.de>:

[.. Änderungen und Verschiebungen von Partitionen]
> 
> Lief alles gut - zu gut, wie sich beim Booten herausstellte. Nachdem
> Grub sich angekündigt hatte, erschien (wie gewohnt) der Splashscreen
> mit dem hin- und herwandernden Balken. An der Stelle, wo er
> normalerweise beginnt, sich langsam von links nach rechts zu füllen.
> sprang die Darstellung um auf Textmeldungen. Nach Beendigung des
> Bootvorgangs und Zugriff auf "Normalscreen" war alles wieder normal.
> Das Phämomen tritt jetzt immer - d.h. bei jedem Bootvorgang - auf.
> 
> Ich habe mich daraufhin im Netz umgetan, Hinweise auf menu.lst
> gefunden und mir die Datei mal angesehen: Sie identisch mit der auf
> einem daneben stehenden PC, auf dem der Bootvorgang normal abläuft -
> auch hinsichtlich des Splashscreens. Die Einträge lauten:
> 
> kernel		/boot/vmlinuz-2.6.24-23-generic
> root=UUID=ad33b5eb-208b-4b54-8dae-546dcb6a7e83 ro quiet splash
> 
> Was könnte beschädigt worden sein, warum, und wie kann ich es zu
> beheben? 

Offenbar handelt es sich um das Problem "UUID und swap". Gefunden habe
ich das hier: 

http://wiki.ubuntuusers.de/Bootsplash 

(Kapitel 'Probleme und Lösungen'). Komischerweise gab's mit "swapon
-s" kein Ergebnis, dto. bei 'ls -la /dev/disk/by-uuid/' (keine swap
dabei), dto. bei 'blkid'.

Mein Umweg: In noch vorhandener fstab nachgesehen, auf welcher
Partition dort swap zu finden war, und auf dem im Artikel angegebenen
Weg die UUID für ebendiese (sda5) geändert und aktualisiert. Jetzt
funktioniert der Bootscreen wieder normal. Komischerweise aber zeigt mir
'swapon -s' immer noch nichts. 

Ist das normal?

> Ich hoffe nur, dass nicht noch mehr kaputtgegangen ist...
> 
Das hoffe ich immer noch....

Viele Grüße

Rainer