[LVM] pvcreate sieht Partition nicht

Christoph Bier christoph.bier at web.de
Mon Jun 2 16:38:34 BST 2008


Hallo,

Oliver Brakmann schrieb am 01.06.2008 21:39:

> Hi,
> 
> On Sun, 2008-06-01 16:47, Christoph Bier wrote...
>> chris at lotus:~$ sudo pvcreate /dev/sda16
>>   Device /dev/sda16 not found (or ignored by filtering).
>                                     ^^^^^^^^^^^^^^^^^^^^
> Hast Du vielleicht mal den Filter in der /etc/lvm/lvm.conf angefasst?
> Steht da sonst irgendwas verdächtiges drin?

Nein. Das Problem trat auch auf beim Versuch Ubuntu auf dieser
Platte zu installieren (genauer: beim Partionieren vor der
Installation von der Live CD aus) -- eine von mir geänderte lvm.conf
kommt dabei ja nicht in Frage.

> Alternativ poste mal die Ausgabe von pvcreate -vvv /dev/sd16.
> Vielleicht ergibt das einen sinnvollen Hinweis.

Ich schrieb es gerade in der Antwort an Simon. Das Gerät /dev/sda16
(bzw. heute wäre es /dev/sdc16) existiert gar nicht.

> Aber, ganz generell:  Was versuchst Du mit dem Gebilde zu bezwecken?
> Du hast da 12 PVs, die alle auf der gleichen Platte liegen. Warum
> machst Du nicht eine grosse Partition und teilst die dann mit LVM so in
> LVs auf, wie Du sie haben willst?  Dazu ist das LVM ja schliesslich da.

Ich ziehe es vor kleine physikalische Einheiten zu haben, um
mögliche Plattendefekte zu begrenzen (siehe auch meine Antwort an
Simon).

>> Eine Google-Recherche förderte mehrere Hinweise zutage, dass man in
>> einem solchen Fall den Rechner neu starten müsse, damit der Kernel
>> die neue Partitions-Tabelle einlese.
> 
> Das geht mittlerweile auch online: blockdev --rereadpt /dev/sda

Danke für den Hinweis!

Grüße
Christoph
-- 
+++ Typografie-Regeln: http://zvisionwelt.de/downloads.html (1.6)