[ubuntu-cloud] Running the UEC images in VirtualBox - /dev/disk/by-label/uec-rootfs does not exist.

Scott Moser smoser at ubuntu.com
Tue Oct 12 02:07:03 BST 2010

On Tue, 12 Oct 2010, Laurence Rowe wrote:

>   * commented out the line ``mv "${d}/etc/resolv.conf"
> "${d}/etc/resolv.conf.dist"`` - it would not download without it.

Shoot.  Righ after that, should have been a:
  cp /etc/resolv.conf "${d}/etc/resolv.conf"
(Ie, we want to replace the chroot version with the system version that
presumably has sane values).

>   * used i386 rather than amd64

I checked with both.

>   * ran the script under an ubuntu 9.04 VM and copied off the resulant
> .img to convert to .vdi on my mac.

Hm.. I ran under maverick (10.10), and tested virtual box for both i386
and amd64 on virtualbox
$ dpkg-query --show virtualbox-ose
virtualbox-ose  3.2.8-dfsg-2ubuntu1

In virtualbox GUI, I had a
   "SATA Controller" of type "AHCI"

> I'm seeing the same error again. By following the instructions at
> http://www.opensourcery.co.za/2009/09/30/virtualbox-gentoo-and-serial-consoles/
> I was able to log the boot over a virtual serial console:
> Begin: Mounting root file system ... Begin: Running /scripts/lo[
> 2.695607] ahci: Unknown symbol ahci_ops (err 0)
> cal-top ... done[    2.779118] e1000: Intel(R) PRO/1000 Network Driver
> - version 7.3.21-k6-NAPI
> .
> [    2.852090] e1000: Copyright (c) 1999-2006 Intel Corporation.
> [    2.923194] ahci: Unknown symbol ahci_start_engine (err 0)
> [    2.951412] e1000 0000:00:03.0: PCI INT A -> Link[LNKC] -> GSI 10
> (level, low) -> IRQ 10
> [    2.971120] ahci: Unknown symbol ahci_interrupt (err 0)
> [    2.993209] ahci: Unknown symbol ahci_check_ready (err 0)

The unknown symbols are the problem.  Its indicating that you didn't get
libahci.ko into lib/modules/"*-${sver}/kernel/drivers/ata/libahci.ko
and/or the ramdisk didn't get updated.  That said, your 'fixlog' shows
that both of those happened.

+ dpkg -x
+ cp
+ chroot ./mnt env LANG=C update-initramfs -k all -u
update-initramfs: Generating /boot/initrd.img-2.6.35-22-virtual

So the only thing I can understand might have went wrong is that you
didn't get your disk image re-created correctly.

It really looks to me like it "should work" other than that.

More information about the Ubuntu-cloud mailing list