update-grub won't be completed

Suhaib Nabeil snabieel at gmail.com
Thu Feb 7 16:07:43 UTC 2013


Everytime I run update-grub, it finds all Linux images but hangs on the
last one reinstalled the last linux image which is sda8 but the problem
wasn't fixed. I also tried boot-repair and the program hangs during the fix
process. The problem happened after installing 12.10 over an old distro. so
before that I hadn't had any problem.
the fan also becomes noisy because of overheating.
What kind of logs do you want me to post ?
using ctrl + c will terminate it and everything returns normal but because
of this problem I can't use dist-upgrade because it will update my kernel.
I ran update-grub from another distro in my grub and it worked fine. the
problem is with this distro only

Here is a pic to show you what is happening:
http://i.stack.imgur.com/jn2L8.png
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-ca/attachments/20130207/16129f68/attachment.html>


More information about the ubuntu-ca mailing list