Belkin wireless internet sharing on Ubuntu 8.04

geo yaktur at yahoo.com
Thu Mar 5 02:10:50 UTC 2009


No luck. Mine is a Belkin but the version number on mine is too new, version 7032. So frustrating, what a waste of time! Grrrr!! :(

So I put the Belkin into the WinXP Home computer now and I have a small USB wireless ZyDAS WLA-54L WiFi do-hickey adapter which I bought a couple of years ago. The Windows software ran smoothly on the WinXP computer and no problems getting everything installed.

Now as far as Linux goes? What a nightmare!! So now onto my last alternative, this little USB ZyDAS thingy. It "comes" with a Linux driver as well as Windows drivers.....not that the Linux driver does anything except spew errors when you try to run the installer. So I am using Ndiswrapper. For basic websurfing it's simple connections it's adequate.

But now what do I do about setting up my computer to share the incoming Cable internet that arrives at this computer I'm typing on, and rebroadcasting it through the house over this ZyDAS USB adapter?

Is there some software I can set up? I've tried Firestarter but it just complaines that Wlan0 isn't ready (probably because Ndiswrapper is a hack Winpatch solution in lieu of a real Linux native driver).

I have RutilT WLAN Manager installed but it doesn't seem to know what to do either. I try setting up something new and it seems that it just acts as a client, not as a server for redirecting an internet connection.

I had Wicd installed but it didn't help any. So I replaced it with WiFi Radar and created a profile in it. Not sure it's doing anything useful either.

Here are some stats from my machine:

ifconfig

wlan1     Link encap:Ethernet  HWaddr 00:02:72:59:26:ed  
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lsusb

Bus 004 Device 002: ID 0ace:1215 ZyDAS WLA-54L WiFi
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 003: ID 04f3:0210 Elan Microelectronics Corp. 
Bus 001 Device 001: ID 0000:0000  

When I tried to ping the local Windows machine I want to link to mine in order to share this incoming internet connection, I couldn't ping it (fixed IP address).

I followed all of the advice I could find at:
http://ubuntuforums.org/showthread.php?t=91370&page=2
and
http://www.ubuntugeek.com/sharing-internet-connection-in-ubuntu.html

Still nothing. The upstairs Windows computer still can't go on the internet and I still can't see it over Samba as I could before when I used to have a discrete router.

I can't afford a router box now, money is tight, so I have to make this computer-internet-connection-sharing scheme work, no choice.

Anybody?
Thanks,
geo


--- On Wed, 3/4/09, Ryan Steele <rgsteele at gmail.com> wrote:

From: Ryan Steele <rgsteele at gmail.com>
Subject: Re: Belkin wireless internet sharing on Ubuntu 8.04
To: yaktur at yahoo.com, "The Canadian Ubuntu Users Community" <ubuntu-ca at lists.ubuntu.com>
Date: Wednesday, March 4, 2009, 1:57 PM

On Tue, Mar 3, 2009 at 5:33 PM, geo <yaktur at yahoo.com> wrote:
> Hi
>
> I'm trying to configure my Linux computer to serve as a sharing point in the
> house for wireless internet.
>
> I have a newly bought Belkin Wireless G Desktop card installed. And so far
> the only driver support I found is through Ndiswrapper to run the WinXP
> driver for it. I'd like to find a Linux native driver for it.
>
> I need also to be able to take the cable internet coming in by Ethernet and
> branch it off via his Belkin wireless card so the upstairs computer (running
> XP Home) can access internet by it's own wireless device.
>
> So far Firestarter only says the card isn't ready. I don't know why that is
> so. Ndiswrapper claims it is ok?
>
> Can anyone offer assistance?

There is a database of wireless cards that work with Ubuntu here:

https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported

You can look up your particular model and see what is required to get
it working.

I would advise that if the card does not have native Linux drivers
available, and you are able to exchange it for another one, do that.
Life is too short to try getting hardware running on Linux with
Windows drivers. Plus, it sends a message to the manufacturer: stuff
that doesn't work out of the box with Linux gets returned to the
store, and they don't want that.

> Thanks,
> geo
>

-- 
Ryan Steele - rgsteele at gmail.com



      __________________________________________________________________
Ask a question on any topic and get answers from real people. Go to Yahoo! Answers and share what you know at http://ca.answers.yahoo.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-ca/attachments/20090304/cce1951e/attachment.html>


More information about the ubuntu-ca mailing list