ubuntu-ca Digest, Vol 45, Issue 7

Alfred alfred.s at nexicom.net
Wed Dec 10 05:47:18 UTC 2008


Often I've noticed that in the Linux Community there are knowledgeable
people that figure that they are going to have a bit of FUN, with a
Newbie. I've just played around for 6 hours getting the 8.10
installation to get on the Internet with Dial-up.

Well, what can happen with this is DELL's INFO DESK gets so overloaded,
that they drop Ubuntu and go with Vista again. When all their Dial up
customers, have to spend 6-10 hours trying to get it to work! Very few
people are on High speed Internet in the World, lots of people are still
using Dial-up! You that did all this work in making Ubuntu 8.10 a
reality, may see your Growing user base, also have a Black Friday! Hey I
know a little bit about Confusers - I played with them, for about 40
years. Most Newbies have no idea at all. If it Don't work - They use
that DVD or CD as a Drink Coaster! 

In Ubuntu 8.10 32 bit pppconfig comes installed on the DVD edition. So
there is not much need to try to find Gnome-ppp


should read:
[Dialer Defaults]
New PPPD = yes
Stupid Mode = yes                         Is this an actual Command?
Modem Type = Analog Modem
ISDN = 0
Auto DNS = 1
Auto Reconnect = 0
Modem = /dev/ttyS0                        /dev/ttyACM0  does not work at
Baud = 230400                             not sure of this number
because when it dialed up it was very slow in Baud-rate!
Init1 = ATZ                               not ATZ4!
Phone = the IP Phone Number
Username = Login name for IP
Password = Login Password 

This Connects Confuser to the Internet. This Internet Connection I'm
using to send you the E-mail is on another Hard Drive, not the 8.10
Ubuntu, but the 7.10 Ubuntu, so everything has to be written down, or
transferred to a Thumb Drive, then put on the 7.10 Hard drive. So I can
send you this Email. Lots of turning off the Power installing a Hard
Drive, over and over again for many hours to get it all working, not
very EASY at all! Just in this little part of the World I tried to get
people to try out Ubuntu, Windows was so troubling for them, and then we
run into this little bit of FUN! Yah some one was having a little bit of
fun with a Newbie, but as far as adopters in the Dial up Zone goes- Hey
you will quite likely LOOSE 150,000 or more people, just in this little
part of the World! Your expanding user base just got hit with Black

Connecting to the Internet is very Important, and should be very easy,
and in everything up to 7.10 it was real easy! Why Mess with something
that worked very very well, hooking up with Dial-up had a very easy to
use interface. Now it's GONE! 

The pppconfig utility asks for info that becomes available when wvdial
is run.  Yet even having the info after wvdial is run, that info is sort
of confusing. My IP acts like Linux never existed. I can't go to them
with the questions that pppconfig asks, the people in the Office don't
know these things themselves, only billing information, and HYPE! 

What are you THINKING!

-----Original Message-----
From: Mac <dhltd at telus.net>
Reply-To: The Canadian Ubuntu Users Community
<ubuntu-ca at lists.ubuntu.com>
To: ubuntu-ca at lists.ubuntu.com
Subject: Re: ubuntu-ca Digest, Vol 45, Issue 7
Date: Tue, 9 Dec 2008 07:14:49 -0800
Mailer: KMail/1.9.10

On Tue December 9 2008 04:00:10 am ubuntu-ca-request at lists.ubuntu.com wrote:
> Message: 2
> Date: Mon, 08 Dec 2008 14:57:51 -0500
> From: Alfred <alfred.s at nexicom.net>
> Subject: Re: Ubuntu Installation.
> To: The Canadian Ubuntu Users Community <ubuntu-ca at lists.ubuntu.com>
> Message-ID: <1228766271.6846.7.camel at alf-desktop>
> Content-Type: text/plain
> Hi:
> Today I installed 8.10 Ubuntu 32 bit on a 250 Gig Partition. It went
> well in the second time. Just one little problem:
> Here in Brigadoon :) we still have Dial-up and no access to High Speed
> Internet. How does one set up the Modem, and the Dial-up with 8.10. I
> see that there are lots of options in Network Tools, but Dial-up does
> not seem to be one of them. Is there an option to load Dial-up Tools
> from the DVD (I bought the DVD Install from Ubuntu in England, and had
> it shipped here.)
> Any hints or help would be appreciated
> Thank you in advance
> Alfred!

I had to configure a dial-up connection for a friend back in the summer on 
Ubuntu 8.04 and it can be done using wvdial which was packaged with 8.04 to 
make the initial connection using terminal commands.  For a GUI interface, 
after establishing a connection to the Internet, I downloaded and installed 
GNOME PPP which provides a graphics interface that is easy to use.

It took several attempts and was a bit frustrating, but I documented my 
experience and saved it in case I ever needed to re-visit the problem.
Once gnome ppp was installed and configured everything worked perfectly and my 
friend, who knows absolutely nothing about computers, has no problems using 
it daily.

One comment, we were pressed for time and I could not get the internal modem 
working so to save time I purchased a USRobotics USB modem but support for 
internal modems may have improved so you can try.

To use wvdial, you'll need to edit the file:   /etc/wvdial.conf  as root or 
use the sudo command to open the file.   I assume you are familiar with using 
basic editing but if not and you need some hand holding, please ask.

Here's an example of a configuration in  /etc/wvdial.conf that works using a 
USRobotics USB modem.  Save a copy of your existing /etc/wvdial.conf under a 
different name before you replace its contents with those below so if 
everything goes to H you can get back to your starting point.
NOTE that "Modem = /dev/ttyACM0" ends with a zero not a capital "O" 

Code:	[Dialer Defaults]    
New PPPD = yes    
Stupid Mode = yes    
Modem Type = Analog Modem    
ISDN = 0    
Auto DNS = 1    
Auto Reconnect = 0    
Modem = /dev/ttyACM0    
Baud = 230400    
Init1 = ATZ4
Phone = {Insert the telephone number of your ISP} eg. 250 123 1234
Username = {name}  This is the login name to ISP 
Password = {password}  This is the login password to your ISP

After saving the new  /etc/wvdial.conf ,  in a terminal, type:
sudo wvdial

After entering your UBUNTU root password, your modem should dial & connect.

After making the correction and re-trying the connection you should see a 
terminal display similar to that below which indicates you have a connection:

mac at T-61:~$ sudo wvdial
[sudo] password for mac: 
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Modem initialized.
--> Sending: ATDT250 388 5747
--> Waiting for carrier.
ATDT250 388 5747
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Fri Sep 26 20:53:23 2008
--> Pid of pppd: 16576
--> Using interface ppp0
There should be four more lines which list 
--> local  IP address
--> remote IP address 
--> primary   DNS address 
--> secondary DNS address 

If you get that, you have a connection but then I found that I could not 
connect with Firefox due to a bug in Firefox.  That may have been fixed or 
you may not be using Firefox.  If you have a problem, ask for help with that 
one and I will look up my old notes and dig out the solution.

When you do get a connection, use the Synaptic Package Manager to install 
gnome-ppp to get a GUI modem manager.  If you are using Kubuntu it may have 
kppp installed or you can install it using Synaptic.  Kppp provides somewhat 
more detailed feedback on problems that it encounters but gnome-ppp is 
quicker to download over a dial-up connection, requires fewer resources and 
once configured works a treat.

Good luck

More information about the ubuntu-ca mailing list