USB drive error

volksman v0lksman69 at
Fri Aug 15 12:37:29 UTC 2008

I might be wrong but a chkdsk on that partition from Vista may help.  I 
can't remember the error an NTFS partition will barf when it needs to be 
scanned but they will refuse to mount if a chkdsk is needed.

Hope that helps!

Doooh_Head wrote:
> I tried that command.  It worked for some of the USB drives.  I am now again
> suspecting that my external drive is toast.  I will have to try taking it
> out of the external case and see if I can connect it up internally and see
> if it works or not.  I'd hate to lose whats on it, but I have previously
> backed up what I thought was important on it (pictures, etc).  I may have to
> rebuild my music collection, but oh well.
> Now, apparently I can't mount one of my internal partitions.  I have a
> dual-boot machine with Ubuntu and Vista.  I have a 250gb drive, partitioned
> in half, with Ubuntu on one, Vista on the other.  Of course from Ubuntu I
> was previously able to mount and see everything on the Vista partition, but
> for some reason I now get an error indicating that I don't have the
> priveledges to mount it.  The only thing that has changed about the entire
> system is that the Vista system has been in use more than it ever has been
> (my son has been staying with us, and has been using it).  Normally I boot
> to it, run Windows Update and thats the end of it.
> I checked my user priveledges to ensure I had the ability to mount such
> things, and as far as I can tell I do.  I have all of the existing
> priveledges checked-off for my user.
> Anyone have any ideas?
> Doooh
> -----Original Message-----
> From: ubuntu-ca-bounces at
> [mailto:ubuntu-ca-bounces at] On Behalf Of David Vincent
> Sent: August 14, 2008 9:01 PM
> To: The Canadian Ubuntu Users Community
> Subject: Re: USB drive error
> Hash: SHA1
> Doooh Head wrote:
>> After some recent Ubuntu updates, for some reason my USB drives are 
>> all messed up and I'm not sure if one of them is indeed dead or not.
>> Initially I thought that it was just dead but after looking at the 
>> System Log and seeing the following error I am suspecting something is 
>> wrong with my USB drives:
>> Aug 14 19:50:46 ECLIPSE kernel: [34283.272231] usb 2-4: new high speed 
>> USB device using ehci_hcd and address 59 ...
>> Aug 14 19:54:40 ECLIPSE kernel: [34468.837574] usb 2-4: new high speed 
>> USB device using ehci_hcd and address 48
>> The log is full of those messages.  It appears to be scanning through 
>> all of the possible addresses, the address count continually goes from 
>> 1
>> - 127 then starts over again.
>> I have a 500Gb external USB drive, a small thumb drive and various 
>> other USB connected devices (mouse, keyboard, printer) including a 
>> drive-bay mounted card reader that has slots for various memory card
> types.
>> Does anyone know how to resolve this issue?
> specifically:
> sudo rmmod ehci_hcd
> my drive mounted right away.  albeit at USB 1.1 speeds - ouch.
> - -d
> Version: GnuPG v1.4.6 (GNU/Linux)
> QNM3lWdnzsi5D4y/xMsoepU=
> =xLJU
> --
> ubuntu-ca mailing list
> ubuntu-ca at

More information about the ubuntu-ca mailing list