Anyone able to help with ACPI troubleshooting on Hardy 64?

Kirk Bridger kbridger at shaw.ca
Mon Apr 28 17:24:19 UTC 2008


Over the winter I upgraded my machine and purchased a new motherboard.  
A fresh install of Gutsy later and I wasn't able to get the system to 
boot properly.  It would get to the GDM screen, and if left alone would 
within 10 seconds or so do a complete hard freeze.  If I tried to log in 
quickly before the freeze, I'd get the login sound, and sometimes see 
the desktop.  But within a few seconds the entire system would freeze.

After some troubleshooting I found that the issue disappeared when I 
added "acpi=off" to the kernel boot line in grub.

However I'm running a dual proc system here, and don't want to turn off 
ACPI.

I had hoped that the latest kernel in Hardy would resolve the problem, 
but no such luck.

I'm at a loss as to how to troubleshoot this issue.  I've confirmed that 
the BIOS for the mobo is up to date and that ACPI is enabled in it.  
Here's the mobo:

http://www.biostar-usa.com/mbdetails.asp?model=TFORCE%20TF7050-M2

Checking the system logs after a freeze always results in the following 
being the last few lines.

Apr 27 21:08:53 Creativity kernel: [   49.829671] Bluetooth: L2CAP ver 2.9
Apr 27 21:08:53 Creativity kernel: [   49.829676] Bluetooth: L2CAP 
socket layer initialized
Apr 27 21:08:53 Creativity kernel: [   49.833285] Bluetooth: RFCOMM 
socket layer initialized
Apr 27 21:08:53 Creativity kernel: [   49.833301] Bluetooth: RFCOMM TTY 
layer initialized
Apr 27 21:08:53 Creativity kernel: [   49.833303] Bluetooth: RFCOMM ver 1.8
Apr 27 21:08:54 Creativity kernel: [   51.041448] Clocksource tsc 
unstable (delta = -180490522 ns)
Apr 27 21:09:42 Creativity kernel: [   71.850218] gdm[5927]: segfault at 
800696278 rip 7ffadae54d1f rsp 7fffe66ae3c0 error 6
Apr 27 21:09:57 Creativity pulseaudio[6338]: alsa-util.c: Device hw:1 
doesn't support 44100 Hz, changed to 16000 Hz.
Apr 27 21:09:57 Creativity pulseaudio[6338]: alsa-util.c: Device hw:1 
doesn't support 2 channels, changed to 1.

And here is a normal boot with ACPI off, for comparison.

Apr 27 23:03:07 Creativity kernel: [    0.000000] Bluetooth: L2CAP ver 2.9
Apr 27 23:03:07 Creativity kernel: [    0.000000] Bluetooth: L2CAP 
socket layer initialized
Apr 27 23:03:08 Creativity kernel: [    0.000000] Bluetooth: RFCOMM 
socket layer initialized
Apr 27 23:03:08 Creativity kernel: [    0.000000] Bluetooth: RFCOMM TTY 
layer initialized
Apr 27 23:03:08 Creativity kernel: [    0.000000] Bluetooth: RFCOMM ver 1.8
Apr 27 23:03:29 Creativity pulseaudio[5643]: alsa-util.c: Device hw:1 
doesn't support 44100 Hz, changed to 16000 Hz.
Apr 27 23:03:29 Creativity pulseaudio[5643]: alsa-util.c: Device hw:1 
doesn't support 2 channels, changed to 1.
Apr 27 23:06:57 Creativity kernel: [    0.000000] usb 3-2: USB 
disconnect, address 3
Apr 27 23:23:06 Creativity -- MARK --
Apr 27 23:43:06 Creativity -- MARK --

Does anyone have any ideas?  The messages log seems to indicate that 
something is freezing, but not what exactly.

Thanks for any tips, pointers or suggestions.

Kirk





More information about the ubuntu-ca mailing list