after removing dlink wireless pci card, no more wireless connection with any PCI wireless card

JC ubunt2 at
Thu Apr 3 02:03:18 UTC 2008

>From January 2007 upto February 2008, I was connecting to the internet
  using a wired ethernet cable connection.
  But in the month of March 2008, I used a D-Link WDA-2320 RangeBooster
  G Desktop Adapter. This was how I installed it:

  Turned off desktop computer.
  Installed the D-Link PCI adapter to one of the open PCI slots.
  Turned on computer.
  Ubuntu automatically discovered the D-Link adapter.
  All I had to do was choose from the list of 4 wireless networks.

  I don't remember whether I added the network-applet to the panel, or
  whether Ubuntu automatically did, but whichever the case, everytime I
  turned on the computer, I had a wireless internet connection.

  Now, on March 31, Monday, I turned off the desktop computer and
  physically removed the D-Link PCI adapter. I then installed some other
  Wireless PCI Adapter. Let's call this "the no-name adapter". See pic
  at  .
  When I turned on the computer, the network applet had an icon
  indicating that it couldn't find any internet connection.

  So without an internet connection, I went to System | Help & Support
  to try to get my wireless internet connection working.

  I went to section 3.2 (Internet and Networks / Wireless Networking /

  "3.2.1 Check for Device Recogintion.
  Step one tells me to "Open Device Manager" which is found, it says, in
  "System > Administration Device Manager". Actually, I find it in
  Preferences / Hardware Information.

  Step 2 tells me to check to see whether the hardware is recognized. So
  I look through the list and find an entry in "CK804 PCI Bridge".
  Here is some information:

  Marvell Technology Group Ltd.
  88w8335 [Libertas] 802.11b/g Wireless
  info.parent /org/freedesktop/Hal/devices/pci_10de_5c
  info.udi /org/freedesktop/Hal/devices/pci_11ab_1faa
  linux.hotplug_type 2 (0x2)
  linux.sysfs_path /sys/devices/pci0000:00/0000:00:09.0/0000:01:07.0
  pci.product_id (and pci.subsys_product_id) 8106 (0x1faa)
  pci.vendor_id (and pci.subys_vendor_id) 4523 (0x11ab)

  Since it is recognized, I go to Section 3.2.2, as per this step.

  Section 3.2.2 is "Check for Driver"
  Step 1 is "sudo lshw -C network" .
  When the Wireless PCI Card is installed, "sudo lshw -C network" gives:
  *-network UNCLAIMED
  description: Ethernet controller
  product: 88w8335 [Libertas] 802.11b/g Wireless
  vendor: Marvell Technology Group Ltd.
  physical id: 6
  bus info: pci at 0000:01:06.0
  version: 03
  width: 32 bits
  clock: 66MHz
  capabilities: pm bus_master cap_list
  configuration: latency=32"

  (When wireless card is not installed, "sudo lshw -C network" gives a blank.)

  Step 2 says, "If there is a driver listed, then see "Section 3.2.3 --
  Check Device is On."

  3.2.3. "Check Device is On."
  Step 1 says "Many wireless network devices can be turned on or off.
  Check to see if the device is turned on by opening a Terminal and type
  the command: sudo lshw -C network."
  I don't know where in "sudo lshw -C network" it is shown that my device is on.

  Step 2 says "If it is turned on then see Section 3.2.4

  3.2.4. Check for a connection to the router

  Step 1. Open a Terminal and type the command: iwconfig.
  When I do "iwconfig", I get

  lo no wireless extensions.

  eth0 no wireless extensions.

  ---- end of paste of iwconfig-----

  In March 2008 (when wireless internet was working, with DLink), I
  remember that ath0 was the "device" that my Ubuntu computer was using
  to get onto the wireless internet connection.
  But now, there's no mention of ath0 anywhere that I've looked.

  Sections 3.2.4 (Check for a connection to the router), 3.2.5 (Check IP
  assignment), and 3.2.6 (Check DNS) are steps that I don't think I
  needed to check, since my problem is below those sections.


  This no-name wireless PCI card that I tried to install on April 1st is
  brand new, but just to see whether it itself was the problem, I tried
  to re-install a D-Link Wireless PCI Network Card. This time, it
  doesn't work at all.
  In March 2008 (when I was able to get onto the internet wirelessly),
  Network Settings | "Connections tab" had "Wireless Connection" as one
  of the choices. But ever since I've removed the D-Link card on March
  31st, "Wireless Connection" is no longer in the list in "Connections

  I'm writing this from a public computer, so if you gave me all the
  information/advice whithout having to have me respond too many times,
  that would be appreciated. If you do need to ask questions, please ask
  them all at once, so that I can give you all the answers all at once.
  Thank you for your understanding.

More information about the ubuntu-ca mailing list